Windows Server 08 DC - DHCP Stops Working

Twice yesterday, about 12 hours apart, my clients lost network connections. Restarting the DC which runs DHCP solved the problem both times. Upon further investigation there are a couple entries in the event log that seem to point to the problem. Help, how do I fix??

Oh and since seeing the Event ID 10020, I disabled the IPv6 on my network adapter and am only using IPv4. Maybe that solves it?


11:41:05
Event ID 1056
The DHCP service has detected that it is running on a DC and has no credentials configured for use with Dynamic DNS registrations initiated by the DHCP service.   This is not a recommended security configuration.  Credentials for Dynamic DNS registrations may be configured using the command line "netsh dhcp server set dnscredentials" or via the DHCP Administrative tool.

11:41:09
Event ID 10020
This computer has at least one dynamically assigned IPv6 address.For reliable DHCPv6 server operation, you should use only static IPv6 addresses.

11:41:09
Event ID 1044
The DHCP/BINL service on the local machine, belonging to the Windows Administrative domain jpresidence.com, has determined that it is authorized to start. It is servicing clients now.

Open in new window

jpfultonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ThorrssonCommented:
Event ID 1056 can be solved with a couple of steps in this technet article
http://support.microsoft.com/kb/282001
1044 is fine, just indicates that DHCP is authorized in AD
10020 could cause issues, but if you have removed the IPv6 from all NICs your should be good.

1056 may cause DHCP to stop working, but your clients shouldn't lose Connectivity until their leases run out ... Unless there is a DHCP address from the IPv4 on your adapters? DHCP Servers (servers in general) should have a Static or Reserved IP address
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jpfultonAuthor Commented:
Okay I just ran through the suggested netsh routine. There are 3 network adapters on the server, only one of which is physically connected. I disabled the two unused ones at the same time that I disabled IPv6 on the active NIC. I see what you're talking about regarding one of the other adapters on the server getting an address from the DHCP but would that really cause a problem? Certainly unecessary for my purposes anyway so disabling is a good enough solution for me if it works. Also, I find it very strange that all of the clients lose their connection so close to the event id appearing. Like you suggested... they shouldn't have issue until the lease runs out. And, once I noticed what was going on I checked out the IP status of my client and saw that it was stuck in the "Acquiring IP" stage... basically it was clear that the DHCP server was not DHCP-ing.

Unfortunately the problem is intermittent so I can't really close out the question unless I stay problem free for maybe 24 hours or so. Thanks for the help and I'll report back soon.
0
jpfultonAuthor Commented:
Just to be clear the server has a static IP.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

ThorrssonCommented:
A DHCP server with a DHCP address is very messy :) so it could have been the issue.
It may be that the point at which you notice the events is also the time at which the clients are renewing their leases. This couldn't be 100% of them statistically but it could be a larger number of them.
You can reduce the lease time on the server and kill a couple of IT machine leases (your VMs or Desktop/Laptop) to test it out
0
ThorrssonCommented:
The primary adapter has a static IP, though the other adapters had DHCP selected? They were not connected though correct?
0
ThorrssonCommented:
Can you start up a Wireshark session and capture for a bit... see if the DHCP server is responding properly to DHCP requests?
0
jpfultonAuthor Commented:
I've never used wireshark before so not sure if the attached is what you're looking for but here's what I got... Oh and I disabled and re-enabled my client's NIC hoping to force a DHCP request... not sure if I was successful.
0
jpfultonAuthor Commented:
Uh, did I not attach the file correctly?
cap.pcap.txt
0
ThorrssonCommented:
No attachment :)
you can also run a
ipconfig /release
ipconfig /renew
At the command line of a client to force a renewal
0
jpfultonAuthor Commented:
Yeah, I tried a /release /renew but it seemed to have no effect... I assumed it was b/c I'm wirelessly connected. If it did work then you'll see it in the capture.
0
ThorrssonCommented:
Is the capture from the DHCP server or a Workstation that is plugged into a SPAN port? I don't see DHCP lease traffic.
If this capture is your own workstation, can you release the address, *disable all other NICS first* start the capture and then do a renew?
0
ComputerDudeLVCommented:
I would begin with a re-boot of your server if possible.
0
jpfultonAuthor Commented:
The capture is from the DHCP server. What should I do?
0
ThorrssonCommented:
Lets not go rebooting the server just yet
You can let the capture run longer and force a couple or renewals
Or just make sure only one NIC on your laptop is active and then renew it's lease
0
jpfultonAuthor Commented:
System has been stable since 1/1/12. Assuming all is well. Full points awarded. Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.