I cannot open exchange console nor powershell after forefront for exchange install on windows server 2008 R2

I am trying to install MS Forefront for exchange on server 2008 R2.  I cannot open exchange console nor powershell after forefront for exchange install.  The install took several tries as it kept hitting issues like needing a particular version of "configuration Management Console", etc...Bottom line...Exchange was working great until I entered into this nightmare known as installing forefront for exchange and it assocoated components.  Please help...I NEED email back up...

The error message..."The connection to the specified remote host was refused." is returned by both the console and the powershell.  I have run EMTShooter and here are the results:

Welcome to the Exchange Management Troubleshooter!

We recommend that you run the troubleshooter after making changes to
IIS to ensure that connectivity to Exchange Powershell is unaffected.

Checking IIS Service...

Checking the Exchange Install Path variable...

Checking the Powershell Virtual Directory...

Checking the Powershell vdir SSL setting...

Checking the Powershell vdir path setting...

Checking HTTP Port 80...

Checking HTTP Port 80 Host Name...

Testing for errors...

VERBOSE: Connecting to MySERVER.korvanskorner.com


[svrmain.korvanskorner.com] Connecting to remote server failed with the following error message : The connection to the
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExcep
    + FullyQualifiedErrorId : PSSessionOpenFailed
The Exchange Management Troubleshooter successfully completed connecting to:

MySERVER.korvanskorner.com

Failed to connect to any Exchange Server in the current site.

Problem found:

Looking for error...

After each error is resolved, close this window and re-run the tool to check for additional problems.
Korvan63Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Korvan63Author Commented:
I forgot to tell you the error...lol..."The connection to the specified remote host was refused."
0
bhupenderccnaCommented:
To resolve this problem, use one of the following methods:

    Make sure that the MSExchangePowerShellAppPool application pool is running. If the pool is running, try to recycle it. Then, check for errors or warnings in the event logs.
    Make sure that the user who is trying to connect has Remote PowerShell Enabled status. To determine whether a user is enabled for Remote PowerShell, start Exchange Management Shell by using an account that has been enabled, and then run the following query:

        (Get-User <username>).RemotePowershellEnabled


    This query returns a response of True or False. If the response is False, the user is not enabled for Remote PowerShell. To enable the user, run the following command:

        Set-User <username> -RemotePowerShellEnabled $True

    Make sure that WinRM is configured correctly on the server. To do this, follow these steps:

            Run WinRM Quick Config. To do this, click Start, type WinRM Quick Config in the Start Search box, and then press ENTER.
            Make sure that both tests pass and that no actions are required. If any actions are required, click Yes in the prompt window to allow the WinRM configuration changes to be made.
            Click Start, type cmd in the Start Search box, and then press ENTER. In the Command Prompt window, type WinRM enumerate winrm/config/listener at the command prompt, and then press ENTER.
            Make sure that a listener exists for the HTTP protocol on port 5985, and that the listener is listening on all addresses.
0
Korvan63Author Commented:
Yes I found that also and was able to test everything except the part about making sure the user has remote powershell enabled.  I cannot test that as I cannot get exchange powershell to open.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

bhupenderccnaCommented:
Dear Korvan,

Have you checked all Exchange Services..please paste here what application logs are are getting related to Exchange.
0
Korvan63Author Commented:
In the application log I see "MXExchangeMailSubmission erros stating "The Microsoft Exchange Mail Submission service is currently unable to contact any Hub Transport servers in the local Active Directory site. The servers may be too busy to accept new connections at this time."  I checked the exchange transport service and it was down so I started it... and tried to open powershell with the same result...so I checked the application log again and found this error:

The service will be stopped. Reason: Microsoft.Exchange.Transport.TransportComponentLoadFailedException: Loading of component 'AgentComponent' failed. ---> Microsoft.Exchange.Transport.TransportComponentLoadFailedException: The agent component failed to load. ---> Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'Microsoft.FSS.AntiSpam.ConnectionFiltering.ConnectionFilteringAgentFactory' from assembly 'C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\agents\FSEAgent\Bin\Microsoft.FSS.AntiSpam.dll' due to error 'Invalid agent assembly path.'. ---> System.ArgumentException: Invalid agent assembly path.
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)
   at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents)
   at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup)
   at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup, Boolean isBridgeHead, String installPath)
   at Microsoft.Exchange.Transport.Extensibility.AgentComponent.Load()
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Transport.Extensibility.AgentComponent.Load()
   at Microsoft.Exchange.Transport.SequentialTransportComponent.<>c__DisplayClass2.<Load>b__0()
   at Microsoft.Exchange.Data.Directory.ADNotificationAdapter.RunADOperation(ADOperation adOperation, Int32 retryCount)
   at Microsoft.Exchange.Data.Directory.ADNotificationAdapter.TryRunADOperation(ADOperation adOperation, Int32 retryCount)
   at Microsoft.Exchange.Transport.SequentialTransportComponent.Load()
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Transport.SequentialTransportComponent.Load()
   at Microsoft.Exchange.Transport.Components.Activate()

0
bhupenderccnaCommented:
Hey have you checked your NIC, please check you must need to get enabled IPv6
0
Korvan63Author Commented:
I just checked and IPv6 is enabled on both LAN and WAN nics

0
bhupenderccnaCommented:
Open the ADSIEDIT and check for the Organiztion Name under the Configuration Container.

If you have Multipe DC then Force Replicate between them from Sites & Services.

Then try running the setup /PrepareAD [/OrganizationName: <organization name> ]

Type the Same Organization Name as shown in the ASIEDIT in the commandlet.
0
Korvan63Author Commented:
Results of setup seems to start then just stop...

PS C:\temp\emtshooter> setup /PrepareAD /OrganizationName: korvanskorner.com

Welcome to Microsoft Exchange Server 2010 Unattended Setup

Preparing Exchange Setup

    Copying Setup Files              PS C:\temp\emtshooter>
PS C:\temp\emtshooter> setup /PrepareAD /OrganizationName: korvanskorner.com

Welcome to Microsoft Exchange Server 2010 Unattended Setup

Preparing Exchange Setup

    Copying Setup Files              PS C:\temp\emtshooter>
0
bhupenderccnaCommented:
You are working with VM or Dedicated Server...
0
Korvan63Author Commented:
Dedicated Server running IIS7, exchange, partial Forefront, AD, DHCP, dns...
0
bhupenderccnaCommented:
Something is looking wrong with AD please apply SP3 and run dcdiag /fix and netdiag /fix on the DC's and make sure that they point to their selves as DNS server and try again
0
Korvan63Author Commented:
I have quite a few updates to run so I will do that then apply SP3 and run dcdiag and netdiag commands and post results...

It seems to me that forefront has altered the transport agents as forefront inserts itself between Exchange and LAN/WAN.  I'm thinking that the partial install did that but did not create the transports needed to continue mail flow...Does that sound reasonable?

0
bhupenderccnaCommented:
Not sure about it..let me investigate with my lab then only could ans this...
0
Korvan63Author Commented:
OK...TYVM
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
0
Kamalasekar ParthasarathyMessaging SupportCommented:

Did you reboot you server and check it out. if your able to mount the stores
0
Korvan63Author Commented:
Jordannet:  I have tried thos as stated above but I cannot check the permissions as I cannot connect to my Exchange Instance.

sekar: Yes I have rebooted several times.  No difference.

bhupenderccna: I cannot find a SP3 for server 2008 R2 But I DID install the latest (SP1) and installed that then ran dcdiag.  The results are attached... dcdiag.txt
0
Korvan63Author Commented:
I found an answer that at least allows me to open Exchange PowerShell and the exchange console.  In IIS, under application pools is the "MSExchangePowerShellAppPool".  Under advanced settings was the option of "Enable 32-bit applications"  That was set to true.  I have a 64-bit OS so I set it to False and the powershell and EMC now open.

I still cannot send receive email but it's progress...lol
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Korvan63Author Commented:
I found this solution through trial and error
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.