Win XP Rro does not boot--blue screen of death.

Hi,
I'm running a Win XP Pro SP3 box.

When windows loads, I get stop error 0000007B.
(0xF78AA524, 0xC0000034, 0x00000000, 0x00000000)
No other info is given.

I think it may be a corrupted MBR???  I had to fix the MBR via Recovery Console a 4-5months ago.

I reboot the computer with the Wix XP Pro installation CD attempting to get to the recovery console.

While in the Windows Setup phase of the install I get a stop error 0x000007B (0xF78AA534, 0xCOOOOO34, 0xALLZEROS, 0xALLZEROS)
 and pci.sys - pci.sys address f748e0bf base at f74870000 date stamp 3b7d855c.

The last message I see when windows is loading preinstallation files is: "Windows is starting...

I don't have backups of the C drive, but I have a Win98 boot diskette to DOS.  Chkdsk and scandsk found no errors.  I also have MBRTOOL.exe but no mbr backups.  I can't even reinstall windows because it dies immediately before the steup/recovery console screen.

I don't have anything except a busted system. LOL!

This is occurring on a ozc 60MBSSD drive.

Any ideas on how to fix this error without getting a new HDD.  

LVL 1
IT79637Asked:
Who is Participating?
 
NrisimhaConnect With a Mentor Commented:

Hello,

There can be a hundreds of problems why your Wix XP Pro can't boot.

Did you try to press F8 key and choose option "Last known good configuration"?

Try first that. If it will not work then look at your Wix XP Pro installation CD does it is a totally clean and try to clean that Wix XP Pro installation CD.

Then try to boot and go to Recovery Console and choose Repair option.

good luc
k
Nrisimha

0
 
web_trackerConnect With a Mentor Commented:
Yes you could definitely be experiencing some type of hardware issue especially since you are experincing problems attempting to boot from the xp cd. I would try downloading a copy of the Ultimate boot disc, and see if you can boot from this disc, you can run tests on the memory or hard drive using this disc. You can download the disc from: http://www.ultimatebootcd.com/download.html

If after running the tests on the UBD, and everything tests fine then you know the problem is not hardware related, if problems occur and you can even boot off the UBD then you have some type of hardware issue. Let us know what happens so we can troubleshoot further
0
 
edbedbConnect With a Mentor Commented:
This is most likely because the HDD controller driver is missing or corrupt. You can either follow the instructions here to install them.
http://www.biermann.org/philipp/STOP_0x0000007B/

Or, you can fix it easily with UBCD4Win
Start your computer with  UBCD4W boot CD
If you don't already have a copy then make one, it is well worth the effort.
http://www.ubcd4win.com/downloads.htm

To fix the drive controller error click Start>Programs>Registry Tools>Fix_HDC>Fix hard disk controller.
After that restart the computer and it's done.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
fleamourianConnect With a Mentor Commented:
XP does not play friendly with SSDs.  There are some ugly hacks out there but you need at least 7 to run a SSD I believe (I stand to be corrected.)
0
 
nobusConnect With a Mentor Commented:
that is correct - XP does not have the trim option
intel has a toolbox, but it only runs on intels; so if OCZ does not have onefor you - sorry
here their tool site :  http://www.ocztechnology.com/ssd_tools/
0
 
MikeKAtLCSConnect With a Mentor Commented:
I have a Seagate Hybrid drive that I have been trying to ghost to.  I finally gave up.  This was a Windows 7 laptop.  Same issue you are having with XP.
0
 
IT79637Author Commented:
Here is where I am at now, but don't know if the info below will solve the problem. Perhaps you will be ab able to define the exact error or come to an educated conclusion  and can tell me what my options are!

1.  Computer boots, but is sometimes it works a little (run one application) or it freezes up.

2.  Ran chkdsk c: /f twice.  Chkdsk finished normally.

3.  Ran emsisoft a2quared anti-malware & all problems were quarantined.  No errors were found in any of the OS directories.

4. I made a list of errors from Event Viewer.  The errors are in the Application and System categories.

5. I can print a document from NotePad.  The printer is attached to PC "data server" running Win200k pro.

6.  Via explorer, I cannot get to a mapped HDD on the "server" box.

7.  Start button, Run fails to launch explorer.  Double click "my computer" and explorer does not launch.

If I tried more things, I sure it would be hit and miss.  No pattern that I can find.

I still can't confirm what the error actually is.  I don't know if it is a corrupted program (svchost.exe), a corrupted file system on the C drive, a TRIM problem as suggested above, or ???.

If Svchost.exe is corrupted, it seems that no services would start.  However, many start while many fail to start.

Below is good representative list of the errors the computer encounters when starting the OS.  It's a bit difficult to read, but there is a definite pattern with:
1.  CI service and
2. Many other services that are supposed to start automatically, but don't.

The list shows errors in the Application and System categories.

Here it is!

Application Category.

1.  Source: Ci
    Category: CI Service
    Event ID: 4126
Cleaning p corrpt content index metadata on c:\system volume information\catalog.wci.
Index will be automaticaly restored by filereing add documents.

2. Source: SecutiryCenter
   Category: None
The Windows Security Center Service was ubable to establish event queries with WMI to
monitor third party AntiVirus & Firewall.

3.  Source: EventAgnt
    Category: None
TraceLevel parameters not locate in registry; Default trace level used is 32.

4.  Source: EventAgnt
    Category: None
    Event ID: 1003
TraceFileName parameter not located in registry; Default trace file used is.
(NOTE -  this seems to be an incomplete error message)

5.  See 1. above.

6.  See 2. above.

7.  See 3. above.

8.  See 4. above

9.  See 1. above.

10.  See 2. above.

11.  Source: CI
     Category: CI Service
     Event ID: 4132  Type: Warning
12.  1 inconsistencies were detected in PropertyStore during recovery of catalog
c:\system volume  information\catalog.wci

13.  See 3. above.

14.  See 4. above.

15.  Source: Application Error
     Category: (100)
Faulting application svchost.exe, version 5.1.2600.5512, faulting module winhttp.dll,
version 5.1.2600.5868, fault at address 0x0000963e.


System Category.
----------------

1.  Service Control Manager
    Category: None.
    Type: Error
    Event ID: 7032
The Service Control Mnager tried to take a corrective action (Restart the service)
after the unexpected termination of the Windows Management Instrucmentation service,
but this action f

2.  Source: Service Control Manager
    Category: None.
    Type: Error.
The TrueVector Internet Monitor service terminatede unexpectedly.  It has done
this 1 times(s).
--------------------------------------------------------------------

Note there are several "Service Control Manager: errors a row. These errors occur in
groups large groups of around 30 errors back-to-back.
The source is "Service Control Manager".
All of the error messages are as follows:  
  A. The XXXXXXXXX service terminated unexpectedly.  It has done this 1 time(s).
Where XXXXXXXXX is:
 Automatic Update
 Security Center
 Windows Management Instrumentation
 Windows Time
 Distributed Link Tracking Client
 Themes
 System Restore Service
 Shell Hardware Detection
 Windows Firewall/Internet Connection Sharing (ICS)
 System Event Notification
 Task Scheduler
 Workstation
 Server
 Help and Support
 COM+ Event System
 Error Reporting Service
 Logical Disk Manager
 DHCP Client
 Cryptographic Services
 Computer Browser
 Background Intelligent Transfer Service
 Windows Audio
 Remote Access Connection Manager
 Telephony
 The following boot-start or system-start driver(s) failed to load:a2injectiondriver.
 Automatic Updates
 WRamDisk
 Parallel port driver

The above errors repeat multiple times in Event Viewer - System category.
-----------------------------

Computer Management (Local)
---------------------------
1. System Tools
2. Storage
  a. Removeble storage
  b. Disk Defragmenter
  c. O&O Defrag Pro Edition
  d. Disk Management --  Unable to connect to Logical Disk Manager service
3. Services and Applications

0
 
IT79637Author Commented:
Thanks for taking a look!
0
 
edbedbCommented:
Check your RAM. Try reseating the modules. Replace it or try starting the computer using 1 memory module at a time in different slots.
0
 
IT79637Author Commented:
Attached screen shot of Event Viewer Application Popup errors.
ApplPopupErr.jpg
0
 
IT79637Author Commented:
The above errors just go on and on and on and never stop....
0
 
rpggamergirlConnect With a Mentor Commented:
Try uninstalling A-Squared anti-malware or any program belonging to A-Squared and see if the helps.
Could just be the A-Squared program playing up.
0
 
nobusConnect With a Mentor Commented:
maybe faster doing a backup and fresh install
0
 
IT79637Author Commented:
The endless errors always give this message below.  When I click OK, the another message box comes up and asks if I want to debug the error with visual studio just-in-time debugger.

I have booted the OS using each memory module in the two slots. So that is 4 different memory configurations.  The errors persist.

Given the error message and trying different mem configurations, this leads me to think it is a memory issue.

However, I still cannot rule out a C drive error.

First,  I'll try purchasing  new memory.  If that does not work then, I need to decide if to I want to go with a  new HDD or a new SSD with TRIM support!

If I go with a new drive, the I'll first take a backup of c dirve and restore to the new hdd or ssd.  If that does not work, then i guess it is a clean install starting with the OS (yuck).
MemError1.jpg
0
 
nobusConnect With a Mentor Commented:
>>  a new SSD with TRIM support!   <<   it is not the SSD model that has trim - it is the OS -  and XP does NOT have it
 
0
 
IT79637Author Commented:
If I upgrade to Windows 7, will that solve my problem?
0
 
nobusConnect With a Mentor Commented:
yes, it has native trim support; be sure to set the Bios to AHCI for the drive
0
 
IT79637Author Commented:
Quote: nobus:

>>  a new SSD with TRIM support!   <<   it is not the SSD model that has trim - it is the OS -  and XP does NOT have it


If I understand Nobus's comment correctly,  I cannot use an SSD on a Win XP Pro OS even if the SSD has TRIM support.  Is that correct?


Therefore, my very recent purchase of OCZ Agility 3 SSD, which has TRIM, will not work correctly on a Win XP Pro OS? Is that Correct?  

0
 
IT79637Author Commented:
I found this information on the Web:

"In order to work correctly, TRIM has to be supported by both the solid-state drive and the operating system you are using."   From http://solid-state-drive-review.toptenreviews.com/what-is-trim-support.html

Seventh paragraph from top.


The author uses the word both,  therefore my Vertex Agility 2 SSD (no trim support) will not work on Windows 7?

If the OS supports TRIM, then why is it on the SSD?
0
 
nobusConnect With a Mentor Commented:
you can use it, but it won't be optimal (see for info on trim - what it does)
so your statement in the previous post "my very recent purchase of OCZ Agility 3 SSD, which has TRIM, will not work correctly on a Win XP Pro OS?" --> IsCorrect?  
for your last post -  it will work  also -  but also not optimal
0
 
nobusConnect With a Mentor Commented:
0
 
IT79637Author Commented:
nobus:
Going back to the original problem(s):

1. What's driving me to drink are the annoying error messages about svchost.exe memory every 30-45 seconds.  That problem is staring me in the face way, way too much.  Also, when I go into Services, half of the services that are supposed to load "Automatic" do not.   The error messages, I assume, result from Win XP attempting to restart services that fail to start the after I logged into XP.

2.  I don't think the boot sector on the C: drive is corrupt.(?)  I am able to boot to XP.

3.  About every 30-45 seconds I get  the very annoying error message that svchost.exe failed with a memory error.   As edbedb suggested, I booted the system using each  memory module individually in each memory slot on the motherboard.  Still got error messages.  I have a HDD with Ubuntu OS.  I swapped drives and Ubuntu ran fine with no problems.

4.  edbedb said to make Win4ubcd boot disk. I created it, but I have not tried to boot from it and enter the command, Start>Programs>Registry Tools>Fix_HDC>Fix hard disk controller.

5. My comment above "my Vertex Agility 2 SSD (no trim support) will not work on Windows 7?"  My statement is incorrect. What I am hearing folks say is that an SSD with or w/out TRIM will work on Windows 7.

FYI -. The SSD is about a year old and the PC is used heavily  8-10 hrs a day..


I see two issues:

1. Using an SSD with out OS TRIM support will degrade performance and eventually make the PC unstable.
2.  Memory errors caused by services failing to start.
What I don't understand is the connection between svchost.exe memory errors  and SSD with no TRIM support on Win XP?

Could someone please explain that to me or if I have not defined/understood the problem correctly what is it?


0
 
nobusCommented:
1- seems a corrupt OS to me - did you run sfc or a repair yet?
http://www.updatexp.com/scannow-sfc.html                        SFC use in XP
http://www.michaelstevenstech.com/XPrepairinstall.htm            Repair install  XP
2-looks correct to me
3-sinc e ubuntu runs fine, the hardware looks ok to me; so again it points to the OS (can you do a fresh install on another disk or partition to test?)
4-i know nothing about it, best lleave that up to edbedb
5-that is what i said, it will work, but -from the wiki page : "More recent SSDs will often contain internal idle/background garbage collection mechanisms that work independently of TRIM; although this successfully maintains their performance even under operating systems that do not (yet) support TRIM, it has the associated drawbacks of increased write amplification and wear of the flash cells"
 so - to summarise :
in XP (no trim support) in order for it to work, you best have an SSD that has the mechanism as above, otherwise you'll suffer a performance penalty
in Vista or W7 that has trim support - no problems (and i does not need an SSD with this mechanism
0
 
nobusConnect With a Mentor Commented:
i don't know how this influences the errors you have,  but it can be related
now - does your sssd have trim?


also , you asked "If the OS supports TRIM, then why is it on the SSD?   "  that i explained above, for the OS'es that do not have TRIM
0
 
IT79637Connect With a Mentor Author Commented:
nobus:

Thank you very much for your detailed explanation of the TRIM issue!  I understand it now.

I attempted do a windows repair from the installation disk, but was never got the screen where I can choose "repair".  I actually ran the install twice.  Now I have three options to boot   "Micro....XP Professional" from:
1.  C:\Windows - loads OS O.K & have all applications, but still get svchost.exe errors.
2.  C:\Windows.0 - this was a aborted install.  It is still in the last phase of the installation.  I have not attempted to complete it, and won't.
3.  C:\Windows.1 -  Clean install, no applications.  

Obviously, I will delete 2 & 3 above and keep working the problem.

Also, you asked 2 questions above:
Yes, the new SSD has TRIM - ocz agile 3, 60G.
Yes, I agree the OS is corrupted.  Will follow up on the two links you provided.  

Thank you very much.
0
 
nobusCommented:
be care ful with deleting, be sure you know which one has the booting info (normally the first)
0
 
IT79637Author Commented:
In the end, I did a complete rebuild of the OS.    The OS was damaged.  Upgrading to Win7 directly or via Vista wold solve the damaged os and TRIM issue using an SSD on XP.

Thanks to all for your help!!!!!
0
 
IT79637Author Commented:
I got a lot of good information and advice!!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.