exchange 2010 services won't start

Exchange 2010 Server unexpectedly rebooted do to power issue.
No services start EXCEPT the information store.
Errors seem to be related to address book in event log.

Watson report about to be sent for process id: 6352, with parameters: E12, c-RTL-AMD64, 14.01.0355.002, M.E.AddressBook.Service, M.E.AddressBook.Service, M.E.A.S.AddressBookService.<DeferredServiceStartInitialization>b__6, System.BadImageFormatException, 546b, 14.01.0355.002.
ErrorReportingEnabled: False


Also:

An unexpected error occurred while starting the Microsoft Exchange Address Book service. Error details: System.BadImageFormatException: Could not load file or assembly 'Microsoft.Exchange.Data, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The module was expected to contain an assembly manifest.
File name: 'Microsoft.Exchange.Data, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
   at Microsoft.Exchange.AddressBook.Service.AddressBookService.<DeferredServiceStartInitialization>b__6()
   at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(TryDelegate tryDelegate, FilterDelegate filterDelegate, CatchDelegate catchDelegate)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Any service I try to start manually gets a 1053 error. Service did not respond to the service request.

Cannot rerun the setup or reapply SP1 with any switches.
Always says Exchange server setup encountered an error.
Even the recoverserver switch.

At a loss but I do have valid system image and backups.
Trying to repair first before going down that path.
jcianciaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PradeepCommented:
If this is not a DC, then check the connectivity to DC and Once try restarting AD Topology service
0
jcianciaAuthor Commented:
No, it is a DC. I have just setup a Hyper-v server and was going to migrate the Exchange piece off to that when this happened. Any thoughts how to proceed?
0
ChrisCommented:
if its a DC as well run a DCDIAG test to see if there is anything wrong with AD.

Are there any other services that are able to run (not just exchange ones)
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

jcianciaAuthor Commented:
Had to reinstall everything from scratch. No solution here worked.
0
jcianciaAuthor Commented:
No solution here worked. Had to reinstall.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ChrisCommented:
did you use recoverserver option or just reinstall?
0
jcianciaAuthor Commented:
Nothing worked. Had to reinstall
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.