windows update

When I try and run windows up date I get an error code 80246008. it tells me that I need to start BITS Serivce. when I try and start it I get error code 1068
marshootAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ivano ViolaSystem AdministratorCommented:
Try the following article from Microsoft to troubleshoot the problem:

http://support.microsoft.com/kb/910337

Let me know if this doesn't help.

IV
0
Dan MuzrallEHS SpecialistCommented:
Which version of Windows are you running?

As a first step, open the command prompt and run the command SFC /SCANNOW
The System File Checker (SFC) has fixed the errors you mentioned for me and many others.

For a couple of machines where the SFC command hasn't worked, I ended up doing repair Windows installs to resolve the issue.

Some other references to check:
http://windows.microsoft.com/en-US/windows-vista/Windows-Update-error-80246008
http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/windows-update-bits-error-80246008-and-more-please/51ca21ff-fe75-456d-9240-b4743f7f6708
0
marshootAuthor Commented:
moonie it will not let me run microsoft fix it. it says I do not have permission, but I'm the only person on this laptop and I know I'm the adminstrator
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

marshootAuthor Commented:
also command prompt is ot a selection uner system tools.

I really think I have been Hacked, because I have ran housecall. and malwarebytes and none of them has found any virus. during the week, my laptop likes to go to sleep on it's own. I have all of my poser setting set to never go to sleep, but it does any way
0
rpggamergirlCommented:
Did you check to make sure that (BITS) path to executable is correct? sometimes some malware modifies the path to executable.
 
Highlight on "Background Intelligent Transfer Service" rightclick and click on properties and check to make sure that "Path to excutable" points to --> C:\WINDOWS\system32\svchost.exe -k netsvcs
making sure that it's an "S" on System32 and not a "F" for Fystem32.


Has this PC been infected before?(even though it's clean now).


0
marshootAuthor Commented:
it is an S and yes I had the vista protection 2012 virus, but yes it is clean now, it have been clean for about 3 days. I ran 3 spyware checks and all came back clean
0
rpggamergirlCommented:
Maybe some services had been deleted.
Also check to make sure these services below are running, or check in the event logs if there are any "This service might not be installed" error and what service they are.

Oftentimes these services are deleted by these rogues, if so then you can just export the keys from another PC.
Base Filtering Engine (BFE)
Windows Firewall (mpssvc)
Security Center (mscsvc)

0
marshootAuthor Commented:
all of the services that you listed are running I don't see anything in the event log that says any services are missing
0
rpggamergirlCommented:
When you check in the services (services.msc) is the Background Intelligent Transfer Service (BITS) stopped?
If it's permisions issue, try taking ownership of this folder might be the same problem with the thread below --> C:\Users\All Users\Application Data\Microsoft\Network\Downloader
See this link:
http://www.sevenforums.com/windows-updates-activation/160231-update-error-80246008-bits-unable-start.html

Can also try changing permissions on these keys:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BITS]
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wuauserv]

If no joy and Norton is installed, try this link;
http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/windows-update-error-code-80246008-on-system/c064f0eb-4a17-4c35-97e8-53b3bfb246ea
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
marshootAuthor Commented:
rpggamergirl. your link is for windows 7 I have vista ulimate x64 I can not find those folders on the c:
0
rpggamergirlCommented:
Sorry try searching for the folder, mentioned in the below link:
\Programdata\Microsoft\network\downloader

http://support.microsoft.com/kb/940520
0
marshootAuthor Commented:
I ran regedit and took permission of the two files, and it let me run the updates. Thanks
0
rpggamergirlCommented:
Glad to know the issue is now resolved.
Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.