ftp logon

When I try to log on to our ftp site on our Windows 2003 SBS using Internet Explorer or Google Chrome a small window pops-up with the following message:

"To log on to this ftp server, type a username and password" (Password changes to Email-address when I click the Anonymous checkbox).

The window has two fields and an Anonymous checkbox which I check, the fields are:
Username           Anonymous
Email-address     ieuser@microsoft.com

The above two fields are automatically populated when I click the Anonymous checkbox.

When I click the Logon button the window pops-up again requesting the same information.

This ftp site worked for years but something happened with the dive letter where the data is store so I corredcted that.  I can open the browser on the server and log on to the ftp site but not remotely or from the terminal server connected to the SBS.

What am I doing wrong?

Thanks,
merdeka
merdekaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BTechAUCommented:
Hi merdeka

This article from Microsoft explains the various sections used to limit access to an FTP site. Some of the main points to note:
1. Check the permissions both on the FTP site and also the NTFS (i.e. disk) permissions on the folder in Windows itself.
2. Check that all computers are allowed access (or at least those that you want to have access)

http://support.microsoft.com/kb/816525

As a last resort, you can recreate the FTP site from scratch. Just right-click and select "Stop" on the current FTP site and then create a new site pointing to the same file location/drive/folder. Maybe this will help in case you've overlooked something on the existing site.

Good luck and hope this helps.
B.
0
midwestgurusCommented:
Hi Merdeka,

I've ran into this issue before - I agree with BTechAU but I would like to recommend something as well.

Check out FileZilla FTP Server - it's free and a very good FTP server, it beats the pants off of 2003's IIS FTP.. You will be impressed, it's very simple to admin.

As for your current issue - are you wanting to use local windows accounts for FTP authentication or the Anonymous one?
0
merdekaAuthor Commented:
BTechAU:

I read the article and then deleted and re-instlled the IIS ftp but still no luck.

midwestgurus:

I downloaded and installed the FileZilla FTP Server but I get the following error message when FileZilla FTP Server tries to connect from the SBS:

FileZilla Server version 0.9.40 beta
Copyright 2001-2011 by Tim Kosse (tim.kosse@filezilla-project.org)
Connecting to server...
Error, could not connect to server

If I use the ftp ipaddress (ftp://xx.xx.xx.xxx) I get the pop-up window displaying the Anonymous username and the E-Mail address "ieuser@microsoft.com".

I am using the same server ip address that I use to connect to the server over the web (i.e. Welcome to Small Business Server web page) except I replace the http with ftp.  I suspect the problem may be something like the ip address.

Thanks,
merdeka

 
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

midwestgurusCommented:
Hi again,

I just want to be sure you are using the SBS server as the FTP server correct? So you have downloaded and installed FileZilla FTP server on the SBS server right? If so you may need to go into IIS and stop the Windows FTP server from running then restart FileZilla - only one FTP server can be listening on the same port at a time..

Can you post what the IP address is of the FTP server for me?

Let me know how it goes.

Thx
Travis.
0
merdekaAuthor Commented:
midwestgurus:

I think progress is being made:

Status:      Connecting to xx.xx.xx.xxx:21...
Status:      Connection established, waiting for welcome message...
Response:      220-FileZilla Server version 0.9.40 beta
Response:      220-written by Tim Kosse (Tim.Kosse@gmx.de)
Response:      220 Please visit http://sourceforge.net/projects/filezilla/
Command:      USER anonymous
Response:      331 Password required for anonymous
Command:      PASS **************
Response:      530 Login or password incorrect!

I tried entering a password for Anonymous in the server screen of FileZilla but it doesn't work from my PC FileZilla screen.  Since the username Anonymous must be OK it seems the password must be the problem.

Thanks,
merdeka
0
midwestgurusCommented:
Good deal - So now...

add a user called anonymous and don't select the checkbox for password. then give it a go.. make sure you have a "shared folder" setup..

Give that a shot and let me know how it pans out.. I can bet you will be much happier using FileZilla FTP.. it's a great product.

Travis.
0
merdekaAuthor Commented:
Travis,

I setup a user called Anonymous on the SBS but it requires a password so I set a password.

I have a shared folder setup, it's the same one that was setup for the IIS ftp - where do you specify this folder in Fftp?

Thanks,
merdeka
0
midwestgurusCommented:
I attached a screenshot - but basically hit the icon with just one person and a computer then a Users window will appear and select the new account anonymous and you will see "enable account" that should be checked and right below it a place for password if you uncheck that box you won't be required to have one..

For the shared folders it's in the same place but on the left side of the users window you will see "shared folders" just click on that (make sure you have anonymous user selected first). Then click the add button, browse to your folder then hit OK.

Give that a try. screenshot screenshot
0
merdekaAuthor Commented:
Travis,

All of he menu items and icons on my Fftp are disabled except for File>Connect to server and File>Quit so I can't do anything.  It keeps cycling the following:

FileZilla Server version 0.9.40 beta
Copyright 2001-2011 by Tim Kosse (tim.kosse@filezilla-project.org)
Connecting to server...
Error, could not connect to server
Trying to reconnect in 5 seconds
Reconnecting to server...
Error, could not connect to server
Trying to reconnect in 5 seconds
Reconnecting to server...

I can see the screen is the same screen as you are using but everyting is disabled.

Thanks,
merdeka
0
midwestgurusCommented:
Ah.. make sure that IIS FTP server is stopped - sounds like it may be conflicting and the FileZilla server isn't starting.. There is an option to run FileZilla server as a service too.. I can help with that if needed, but for not go back into IIS and make sure the IIS FTP server is stopped and let me know how it goes.

Travis.
0
midwestgurusCommented:
typo.. For now check IIS and kill/stop any Windows FTP server from running then try to re-launch the FileZilla Server..

Thanks! :)
0
merdekaAuthor Commented:
Travis,

I opened Sevices in Computer Management (local) and disabled FTP Publishing Service and started FileZilla Server FTP Server (in the same Services screen).  Now under IIS FTP Sites are shown as disabled however Fftp icons and menus are still disabled and the FTP Server cannot connect to 96.53.50.254:21 or :14147.

Thanks,
merdeka.
0
midwestgurusCommented:
What is the IP address of the SBS server? Is it 96.5.50.254?

Try to go to File -> Connect to Server -> then for the server address use 127.0.0.1 port 14147

See if it's something with that address.. I'm also assuming you are opening the FileZilla Server Interface from the SBS server itself..

Hope that does the trick - if not, for some reason the server isn't listening for FTP - but if you still can't connect after changing the IP to 127.0.0.1 let me know and I'll walk you through some stuff..

There is a command you can run called netstat with an option of -ab (netstat -ab) this will show you all the applications/services running and what ports they are listening on..

0
merdekaAuthor Commented:
Travis,

The server ip address is 96.53.50.254.

On the SBS I entered 127.0.0.1 in Fftp and got the following result:

FileZilla Server version 0.9.40 beta
Copyright 2001-2011 by Tim Kosse (tim.kosse@filezilla-project.org)
Connecting to server...
Connected, waiting for authentication
Logged on

So that works.

merdeka
0
midwestgurusCommented:
Good deal - now you should be able to make the changes needed.

my guess is the FileZilla FTP server was trying to make an outside connection.. so for future use just use the loopback address 127.0.0.1 to manage the FTP server..


You should be able to make changes now - let me know how it goes with the settings I recommend.

Thanks!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
merdekaAuthor Commented:
Travis,

I just noticed that when it connected to 127.0.0.1 on port 14147 the icons became enabled.

I will go back and look at your screenshots.

merdeka
0
midwestgurusCommented:
No problem - Thanks :)
0
merdekaAuthor Commented:
Travis,

I entered ftp://96.53.50.254 in IE and theftp site pop-up so I entered it in Fftp client and the ftp site appeared.  Wow was that easy :-0.  Just joking.  

I have no idea what was changed to make it work (after the icons were enabled) but it works now and I'm happy.  Should other user use Fftp client?

Thanks,
merdeka  
0
midwestgurusCommented:
Merdeka,

I'm glad that you are up and running now - the reason the icon's weren't enabled is because the FileZilla Server Interface wasn't connected to the server.. so using the loopback address (127.0.0.1) vs. the actual address was the trick to get icons/menus enabled. :)

As for the other users - sure they can use FileZilla FTP Client - it's nice, they can also use other ftp clients as well, it's really personal preference or company standard.

I'm a fan of FileZilla it's a great product and fairly easy to setup and manage not to mention it's stable.

It was nice working with you - if you have any more questions just let me know.

Travis
0
merdekaAuthor Commented:
Thanks again Travis, without FileZilla I probably wouldn't have an ftp site.
0
midwestgurusCommented:
It was my pleasure - glad to share some knowledge and help you out.
0
midwestgurusCommented:
Merdeka - when you have a few moments please remember to mark your question answered, I'm trying to rack up some Expert points :) Just when you have time.

Thanks again!
0
merdekaAuthor Commented:
Sorry Travis, I did award the points yesterday, at least I tried to, but as usual something went wrong.
0
merdekaAuthor Commented:
Let me know if awarding the points doesn't work this time.  It should be 500 points.

Thanks,
merdeka
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.