SSIS Error message when trying to FTP


I have an SSIS package that;
1.Runs a SP to gathers data
2. pushs this data to a CSV file
3. Sends an internal email to the company to show location and sucess of new report generated.
4. FTP's this information to another company site.

Steps 1 to 3 run fine.
I have an issue now with step 4.
I get the following error:
Description: Failed to decrypt protected XML node "DTS:Property" with error 0x8009000B
 "Key not valid for use in specified state.". You may not be authorized to access this information.
This error occurs when there is a cryptographic error.
Verify that the correct key is available.


the Protection level on Security is at DontSaveSensitive in Visual Studio settings.
on the Job that i created on MS, i have set the config file to a perticular location.
The config file is in that location.
but i'm still getting this error.


This job has ran with out error previously.
This was set up by someone else.
I ammended the job by adding on the email capability.
I wonder now, because i uploaded the package, are my credentials causing a problem?

I was also thinking about setting secrutiy Protection level  to '''Encrypt Sensitive with user Key''
And adding a password, but i'm not sure if that is fixing the issue or just covering up the issue?

It should in theroy run ok as i have the FTP setting saved in the declaried config file?

Can any one please help on this?
PutochAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TempDBACommented:
Yes it should be because of the your credentials. Try uploading the document manually by command prompt or tools like cute ftppro. You can also use wget.
If manually you can do it, then its not the credential error.

Regarding the sensitivity of data, I believe that you understand what it means. Still the reference is here included:-
http://www.sqlmag.com/article/encryption2/ssis-package-protection-levels-

You can come up with some problem.. check the following link:
http://social.msdn.microsoft.com/Forums/en/sqlintegrationservices/thread/662f0087-e106-423e-b8fb-248883b79c31
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PutochAuthor Commented:
Thank you.
I can FTP them over using Smart FTP.

But when i'm in the package on VS and i try to only execute the FTP task in question it doesn't work.
I get an error.
I have even tried to change the security settings but it's not working.

I have asked the DBA team about the credientials. Still awaiting response
I will let you know if I can get this working.

Thank you.
0
PutochAuthor Commented:
Strange thing keeps happening.
Every time i save the SSIS package to Don't save sensitive data (so that the config file will be read),
I then import the package back into the Integrated services jobs.
Then i export the package again, and open it up on VS to see if all the settings are ok, and the Protection Level has changed back to Encrypt Sensitve with Password!
How is that happened?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.