bring windows to the front

Here's the question I received:

"anytime anything comes up (like a Skype message, or trying to add a bookmark), it comes up behind the browser window .... I'm not sure why it's doing that (it's only the last couple of days) ........ I know it has to be a setting, somewhere, but I haven't changed anything (nor installed anything that would change settings) ......... :|"

Any ideas on how to make these message windows come up to the front again?
a1electricAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

djdjukicCommented:
Windows 7 has disabled this funcionality, known as "stealing focus".
0
cwstad2Commented:
This article will give you the necessary stept to correct the problem

http://pcsupport.about.com/od/windowsxp/ht/stealingfocus02.htm
0
a1electricAuthor Commented:
that article shows how to stop the windows from coming to the front - the reverse of what we're looking for - do you know the registry value that tells the windows that we do want them to "steal focus" and come to the front?
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

cwstad2Commented:
By some further reading it looks as though a process with continal high cpu may be causing your problem. if you take a look in task manager and end that process does it return to normal
0
djdjukicCommented:
It isn't possible in Windows 7, but can be reenabled in XP:

http://pcsupport.about.com/od/windowsxp/ht/stealingfocus01.htm

by unchecking instead of checking the box.
0
djdjukicCommented:
Actually, now that I think about it, the browser may have just made itself "Always on top"

http://code.google.com/p/chromium/issues/detail?id=15018

Try Firefox or Internet Explorer and see if the issue persists.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
a1electricAuthor Commented:
Hard to tell if this actually fixed it or a simple reboot fixed it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.