How do I force email delivery OUTSIDE of the local exchange server?

I am transitioning my users to a hosted exchange service.  The internal exchange server will continue to function to send emails from our xerox and lanier scanner/fax machines.  One does not support external smtp servers, the other supports external smtp but not SSL (whatever!).  The internal mail server delivers the users' scanned documents to their emails but to the internal mail server and not the external one.  Same with the inbound faxes that are delivered to an A.D. user's mailbox.  I cannot disable all users in the internal server due to validation of the hosting process and general history.  I cannot disable the default smtp address in the recipient policy.  I would like to force ALL email delivery outside my network, no checking for internal addressees.

Any ideas?
keyosdAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BTechAUCommented:
Hi keyosd

What version of Exchange are you running?

Have a look at this sort of thing:
http://www.msexchange.org/tutorials/exchange-2003-smtp-namespace-sharing.html

B.
keyosdAuthor Commented:
exchange 2003.  I made the domain.local the primary smtp address and then deselected the domain.com smtp address completely.  This did not prevent the emails from being delivered to local users first before pushing the email outside the domain.  All users exist in two different locations.  On the internal exch 2003 server, I don't want anything to be delivered to anyone, but I want to be able to send out.  All users are still accessing their email databases on old and new.  If anyone replies to or sends new emails to an internal user from the internal mail server, I want the email to go outside and find its way to my hosted email as defined in the public dns.
BTechAUCommented:
What you're saying is correct. Simply deselecting the domain.com address will not give you the desired result. Have you done this bit:

 Start Exchange System Manager, click Recipients, and then click Recipient Policies.
 Right-click Default Policy or any other created Policy, and then click Properties.
 Click the E-Mail Addresses tab.
Click SMTP and then click Edit.
Check if the Checkbox "This Exchange Organization is responsible for all mail delivery to this address" is activated or not
 
If the checkbox is selected, than Exchange Server is authoritative for that address space. If this checkbox is not selected, this Exchange organization is not authoritative for that e-mail address space.

Then if you read the Mail Flow section of that article it explains what happens when you do this. It should do exactly what you described.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

keyosdAuthor Commented:
yes.  I could not uncheck that box until I made another address the primary.  I made domain.local the primary, then went into domain.com and unchecked that box ("This Exchange Organization...").

Subsequently...  an acceptable workaround:

Leaving the domain.com either not as primary or selected smtp address at all, I went to individual user's object in AD and removed the email address from the "exchange email addresses" tab.  This forced the email outside.  Not pretty, especially if you have a large number of users, but at least it works.

Thanks for input.
BTechAUCommented:
Yes, I agree. In theory, you also could go to the recepient policy, remove the domain.com email and force an update.

Glad you got it sorted.
B.
ArneLoviusCommented:
if I understand you correctly

You have migrated the contents of users mailboxes to a hosted exchange provider.
The users "legacy" mailboxes still exist on the "legacy" exchange server.
You want two network scanners to send email direct to the hosted exchange provider instead of via the "legacy" exchange server.

If you still need to use the legacy exchange server as a "gateway" to get to teh hosted environment, I would suggest adding a secondary domain to the hosted environment that does not exist on the legacy exchange server and then set (via adsiedit) the targetAddress on each user to point to the secondary domain email address, thus forcing the email to be "forwarded" to the externally hosted address.
keyosdAuthor Commented:
changing the default domain was only part of the solution.  removing the individual smtp email addresses from the user objects solved it completely.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.