SBS2008 single server will not update (WSUS) and errors in event log

We have a single SBS200 server which for some reason will not update with WSUS and we also are getting loads of errors repeatedly in our event log, as follows :-

ISAPI Filter 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_filter.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a AMD64 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.

Whether the 2 are related, I am unsure, but I could do with some assistance resolving this, if possible.

If anyone can help, I would be much obliged.
LVL 1
nigelbeatsonAsked:
Who is Participating?
 
nigelbeatsonAuthor Commented:
Please remove this question.

Many thanks.
0
 
Shreedhar EtteCommented:
Open the Command prompt and go to path C:\Windows\Microsoft.NET\Framework\v4.0.30319

type aspnet_regiis -r

It will re-reister .NETv4.030319

0
 
nigelbeatsonAuthor Commented:
We need .netv2 for sbs / exchange and have now re implimented this. However updates do not download still.

Any ideas?
0
 
nigelbeatsonAuthor Commented:
no response to question.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.