windows 7 sp1 error ?

I get this  error when installing windows 7 sp1. "The referenced assembly is not installed on your system". How do I fix this
pcusoftAsked:
Who is Participating?
 
jbronson1Commented:
i found this http://www.sevenforums.com/windows-updates-activation/146737-windows-7-sp1-failed-install-0x800736b3.html it looks like they did a new install again and it worked the second time. you can try all the other solutions first.
0
 
Chris MillardCommented:
As this is a service pack / Windows update issue, you are actually eligible for free support from Microsoft:-

http://support.microsoft.com/ph/6527

Click on Contacts, then choose "Windows Update fails while scanning for, downloading, or installing updates"
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
ded9Commented:
Run system readiness tool

http://windows.microsoft.com/en-US/windows7/What-is-the-System-Update-Readiness-Tool


Reboot and then upload checksur.log for analysis.
Windows\Logs\CBS\CheckSUR.log




Ded9
0
 
ded9Commented:
You can try installing sp1 after running system readiness tool ..reboot is required...if not able to install sp1 then upload checksur.log for analysis.

C:\Windows\Logs\CBS\CheckSUR.log




Ded9
0
 
pcusoftAuthor Commented:
No resolution but thanks for the responses
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.