Please Help with Centos 6 Server

I have installed a CentOS-6.2-x86_64 server with the help of Server-Worldhttp://server-world.info/en/

but after succesfuly installing the server with the following functions Webserver, DNS, Webmin

i cant not access anything on this server including Webmin https://74.92.128.51:10000

but i can connect to the server via ssh from a different network
tunapoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

xtermCommented:
Please ssh in and execute the following commands and paste the output here.

My guess is that you either need to permit it through the firewall, or perhaps its only listening on localhost instead of your actual IP address.
ps ax | grep webmin
netstat -na | grep :10000
/sbin/iptables -nL
/usr/sbin/getenforce

Open in new window

tunapoAuthor Commented:
[root@maskjams ~]# netstat -na | grep :10000
tcp        0      0 0.0.0.0:10000               0.0.0.0:*                   LISTEN      
udp        0      0 0.0.0.0:10000               0.0.0.0:*                               
[root@maskjams ~]# ps ax | grep webmin
 1191 ?        Ss     0:00 /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
 1261 pts/0    S+     0:00 grep webmin
[root@maskjams ~]# netstat -na | grep :10000
tcp        0      0 0.0.0.0:10000               0.0.0.0:*                   LISTEN      
udp        0      0 0.0.0.0:10000               0.0.0.0:*                               
[root@maskjams ~]# netstat -na | grep :10000
tcp        0      0 0.0.0.0:10000               0.0.0.0:*                   LISTEN      
udp        0      0 0.0.0.0:10000               0.0.0.0:*                               
[root@maskjams ~]# /usr/sbin/getenforce
Disabled
[root@maskjams ~]# 

Open in new window


those are the result after using the cold you gave me, but the problem still the same
xtermCommented:
Yes, those are just diagnostic commands so I can see what is wrong.  You skipped the most important one however, please run it and paste the output.

BTW, from the above, I can tell many things:
1)  webmin is installed and running properly
2)  webmin is listening on the correct port (10000) and is listening on all ethernet interfaces
3)  selinux is disabled, so that is not preventing the connection

It's almost certainly going to be iptables.
/sbin/iptables -nL

Open in new window

Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

tunapoAuthor Commented:
[root@maskjams ~]# /sbin/iptables -nL
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED 
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22 
REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited 

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         
REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited 

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
[root@maskjams ~]# 

Open in new window

Thanks for the fast reply
xtermCommented:
Your firewall blocks all except port 22 and icmp.

You need to permit the IP of the machine you're on right now to access the server.  You can find out your IP by going to http://whatismyip.com/ in the web browser on the machine you want to connect from.

Replace the X.X.X.X below with your IP, and then run the comand below.  Then you should be able to go to https://74.92.128.51:10000 without any problems.





/sbin/iptables -I INPUT 1 -s X.X.X.X -p tcp -m tcp --dport 10000 -j ACCEPT

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tunapoAuthor Commented:
great thanks it worked what if i want to allow all connection to my server in general so i could access it from any computer / network like a normal server those what do i  do?
xtermCommented:
Well, this is at your own risk but:

(it will stop your current firewall, and then disable it from starting up at your next reboot)
/etc/init.d/iptables stop
/sbin/chkconfig --del iptables

Open in new window

tunapoAuthor Commented:
Thank you so much
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.