linux shell github error

I got a linux server and recently tried a new package for the fuelphp framework.
Now This is the error I get when using it.

fatal: unable to connect to github.com:
github.com[0: 207.97.227.239]: errno=No route to host

I tried searching google for it, but no specific solution for it.
Anybody able to help me on this?
LVL 3
MutsopAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

farzanjCommented:
Can you ping the IP address?
ping 207.97.227.239

Can you dig it?
dig 207.97.227.239

What is your route setting?
netstat -nr

What command did you issue?

Can you ping your gateway?
0
arnoldCommented:
The error means that it could not connect to the site github.com site.
traceroute 207.97.227.239 is another thing to check.

The issue might have been with your provider unable to find a path or your system at the time was offline.

0
MutsopAuthor Commented:
Pinging works from my server.
Digging I suppose too:

[*****@ns1 ~]$ dig 207.97.227.239

; <<>> DiG 9.3.3rc2 <<>> 207.97.227.239
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 26097
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;207.97.227.239.                        IN      A

;; AUTHORITY SECTION:
.                       10800   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2012010400 1800 900 604800 86400

;; Query time: 32 msec
;; SERVER: 85.17.41.228#53(85.17.41.228)
;; WHEN: Wed Jan  4 17:42:36 2012
;; MSG SIZE  rcvd: 107

netstat -nr gives me (I masked my IP):
[******@ns1 ~]$ netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
**myIP**     0.0.0.0         255.255.255.255 UH        0 0          0 venet0
192.0.2.0       0.0.0.0         255.255.255.0   U         0 0          0 venet0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 venet0
0.0.0.0         192.0.2.1       0.0.0.0         UG        0 0          0 venet0

the command I was using came from a fuelphp (php framework) package
[******@ns1 public_html]$ oil create swtor
Cloning into ./swtor...
fatal: unable to connect to github.com:
github.com[0: 207.97.227.239]: errno=No route to host

Could not open input file: ./swtor/oil
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

arnoldCommented:
not sure whether the http://github.org/swtor/oil should exist, but it does not currently exist and that might be what the error means.
The issue might be that the connection is really via Ftp which does not work.

there should be a log when you run the command to detail what it is trying to do and what commands are being executed.

Check whether there are other sources besides github.com to which oil can be configured to connect i.e. other mirrors.

https://github.com/fuel might be what could help you further
0
MutsopAuthor Commented:
Why would http://github.org/swtor/oil need to exist?

When you check:
http://docs.fuelphp.com/installation/instructions.html

You'll see that to create a new project automaticly you just type
$oil create <projectname>
0
eagerCommented:
What is the output from running "route"?

Can you ping another site, say google.com, using the FQDN, not IP address?

What does /etc/resolv.conf contain?
0
MutsopAuthor Commented:
Sorry for late response,

but got it fixed thanks to the fuelphp forum.

Apparently my TCP port 9418 was blocked.
So now everything works :)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MutsopAuthor Commented:
as stated above it was a port that was blocked
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.