IE8 Z-Index problem

Link: http://test.scic.com/files/durable/aboutus.html

The video goes over the header when scrolling down in IE8. In all others above IE8, it works correctly.

How can I make the video go behind the fixed positioned header?
LVL 26
Eddie ShipmanAll-around developerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle HamiltonData ScientistCommented:
Actually, it only works in FF and IE9. I'm pretty sure it has to do with the Flash video - Flash likes to be on top.

Not an ideal solution, but, If you sacrifice the .topbar position:fixed, you will avoid this problem.
0
COBOLdinosaurCommented:
Try putting this in the head of the page:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

If that does not work then try a z-index of -1 on the flash player.

A final attempt would be a long shot but try going from xhtml transitional to xhtml strict for the doctype.

Cd&
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kumaranmcaCommented:
Change z-index value the below css code refer...

.topbar {
    background: url("../images/bgHeader2.png") repeat scroll 0 0 transparent;
    border-bottom: 2px solid #666666;
    position: fixed;
    top: 0;
    z-index: 0;
}

file core5.css line 86 Change z-index:0;

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Eddie ShipmanAll-around developerAuthor Commented:
@kozaiwaniec,
Removing Fixed is not an option.

@COBOL,
The meta tag, doctype change nor z-index of -1 worked.

Any more ideas?
0
Eddie ShipmanAll-around developerAuthor Commented:
I cannot set wmode because it is being loaded from YouTube.
0
Kyle HamiltonData ScientistCommented:
Kind of a longshot, but what if you put the header in an iframe instead of using fixed positioning?
0
Kyle HamiltonData ScientistCommented:
Sorry, I meant frame, not iframe...

I know, frames can be considered evil, but there's a time and place for everything....
0
Eddie ShipmanAll-around developerAuthor Commented:
OK, modifying the URL to the video to add
?wmode=transparent 

Open in new window

fixed the issue.
0
Eddie ShipmanAll-around developerAuthor Commented:
Found answer on stackoverflow.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
CSS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.