Cannot ftp through windows firewall on sbs2008

I have a strange problem.
Windows firewall is blocking my ftp site.

If I turn off firewall, everything works fine, but as soon as I turn it back on, I will not be granted access.

I have FTP Server in my exception list.
I have tried to add port 21
but no matter what I do the problem is the same.

Can anyone tell me what need to be done, to get it working with Firewall turned on?
bsitAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cy_hungCommented:
Maybe you can try this :

1. Turnooff firewall
2. Connect to FTP site
3. Use netstat -a to check which port is involved.
4. Change firewall settings
5. Turn on firewall and retest

0
cy_hungCommented:
More detail explanation for how network ports works during a FTP connection :
http://slacksite.com/other/ftp.html

You may consider to add exception for the FTP program used instead of the port number, which may change from time to time.
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

delandaleCommented:
Are you accessing or hosting the ftp site from your server?

If accessing, try adding a rule in the firewall to allow all traffic from the ftp PROGRAM you are using.

If hosting, see: http://learn.iis.net/page.aspx/309/configuring-ftp-firewall-settings-in-iis-7/ under the 'Using Windows Firewall with non-secure FTP traffic' section. You need to perform the netsh commands
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bsitAuthor Commented:
Hmm.
I get a whole bunch of ports listed, and all of a sudden, it starts finding lots of lots of ports like
udp    0.0.0.0:53400
udp    0.0.0.0:53401
ect.

It stops after about 20-30 seconds.

I did not really find out, what port was involved.
0
bsitAuthor Commented:
Delandale: The netsh commands did the trick. Now it works!
0
delandaleCommented:
Glad to hear you got it working!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.