• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 654
  • Last Modified:

Cannot ftp through windows firewall on sbs2008

I have a strange problem.
Windows firewall is blocking my ftp site.

If I turn off firewall, everything works fine, but as soon as I turn it back on, I will not be granted access.

I have FTP Server in my exception list.
I have tried to add port 21
but no matter what I do the problem is the same.

Can anyone tell me what need to be done, to get it working with Firewall turned on?
0
bsit
Asked:
bsit
  • 2
  • 2
  • 2
  • +1
1 Solution
 
cy_hungCommented:
Maybe you can try this :

1. Turnooff firewall
2. Connect to FTP site
3. Use netstat -a to check which port is involved.
4. Change firewall settings
5. Turn on firewall and retest

0
 
cy_hungCommented:
More detail explanation for how network ports works during a FTP connection :
http://slacksite.com/other/ftp.html

You may consider to add exception for the FTP program used instead of the port number, which may change from time to time.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
delandaleCommented:
Are you accessing or hosting the ftp site from your server?

If accessing, try adding a rule in the firewall to allow all traffic from the ftp PROGRAM you are using.

If hosting, see: http://learn.iis.net/page.aspx/309/configuring-ftp-firewall-settings-in-iis-7/ under the 'Using Windows Firewall with non-secure FTP traffic' section. You need to perform the netsh commands
0
 
bsitAuthor Commented:
Hmm.
I get a whole bunch of ports listed, and all of a sudden, it starts finding lots of lots of ports like
udp    0.0.0.0:53400
udp    0.0.0.0:53401
ect.

It stops after about 20-30 seconds.

I did not really find out, what port was involved.
0
 
bsitAuthor Commented:
Delandale: The netsh commands did the trick. Now it works!
0
 
delandaleCommented:
Glad to hear you got it working!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now