Sysprep Answer File for Windows 7 - how to skip the Country / Time & Currency / Keyboard Dialog?

Hi Experts,

Just wondering if it's possible to change my answer file (attached) so that the dialog shown below is hidden (i.e. skipped)?

Regards,
Leigh myunattend2.xml
0002.jpg
LVL 1
LeighWardleAsked:
Who is Participating?
 
the_endjinnConnect With a Mentor Commented:
Sorry, you want to have it in the oobeSystem phase and not the specialize phase.
0
 
AhmedHERMICommented:
Hello;

You'd better check the oobe.xml file to see if the hideRegionalSetting setting, the hideTimeAndDate setting, the keyboard setting are correctly configured.
here are some reference links :
http://technet.microsoft.com/en-us/library/dd799310%28WS.10%29.aspx
http://support.microsoft.com/kb/289125

Best Regards.
0
 
the_endjinnCommented:
In the oobeSystem pass you need to add the following component after your Microsoft-Windows-Shell-Setup component. This is for UK English, you would need to look up the relevant language codes for your setup here - http://msdn.microsoft.com/en-us/library/ms533052(v=vs.85).aspx

<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-GB</InputLocale>
            <SystemLocale>en-GB</SystemLocale>
            <UILanguage>en-GB</UILanguage>
            <UserLocale>en-GB</UserLocale>
        </component>
0
 
LeighWardleAuthor Commented:
Hi the_endjinn,

I am pretty sure I followed your instructions, but I still get the dialog.

Here's an excerpt of my answer file showing where I added the "Microsoft-Windows-International-Core" component:

.....
    <settings pass="specialize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <TimeZone>AUS Eastern Standard Time</TimeZone>
            <ComputerName></ComputerName>
        </component>
        <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-au</InputLocale>
            <SystemLocale>en-au</SystemLocale>
            <UILanguage>en-au</UILanguage>
            <UserLocale>en-au</UserLocale>
        </component>
......

I have attached a screendump from WISM (WISM says the answer file is valid).

What is the significance of the Property Enabled = False? (highlighted in Red)?
0004.jpg
0
 
LeighWardleAuthor Commented:
Thanks, that did the trick!
Regards,
Leigh
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.