Auto Reply -RoundCube

Hi,
I need to install the auto -responder for out of office messages using RoundCube.
If anyone clearly understands the steps described in the following links,please put them in order for me so i can do the same;
http://peterruiter.com/2009/07/05/roundcube-webmail-auto-reply-plugin/
http://sourceforge.net/projects/rcubevacation/
I have downloaded the plugin,gone through the readme.txt and the Install.txt but am not getting steps in clear terms;
Anyone that can put things easier for me to follow please help,my boss wants this option to be there for users;
Note:i have searched for solutions in this knowledge-base but non seems to address my concerns
protechzmAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

xtermCommented:
This is a pretty simple installation procedure, but sometimes its confusing to people not familiar with installations, these are the steps.  Can you tell me which one you're getting stuck on?

I'll add my own notes to maybe make the steps clearer:

1)  You may have downloaded vacation-1.9.9.zip (not .tar.gz)   Copy it into the plugins directory wherever roundcube is installed, probably something like /var/www/html/roundcube/plugins.  Then do "unzip vacation-1.9.9.zip" and it will create the vacation folder right there in the /plugins directory
2)  Now go into the config directory, probably something like /var/www/html/roundcube/config and open up the file main.inc.php in a text editor like vi and change this line:
$rcmail_config['plugins'] = array();
  to this:
$rcmail_config['plugins'] = array('vacation');
and then save the file
3) Open the file config.ini in the new folder that was created in step #1  You shouldn't really need to change anything there, but you MUST have the file /usr/bin/vacation on your system for this to work.  If you do not, please do "yum install vacation" to install it (as root)
4) You will need to change ownership of the config.ini file to the user that your webserver runs as.  You can find out what user this is by issuing the following command:
  ps aux | grep httpd | awk '{print $1}' | grep -v root | uniq
It should be something like "apache" or "nobody" or perhaps "www-data".  Whichever it is, substitute that username for $apache_user in the instructions below, and remember you will need to be root to do so. So for example:
  chown apache plugins/vacation/config.ini
5)  Again, as the root user issue the command
  chmod 0400 plugins/vacation/config.ini

Then the next time you log into Webmail, go to the settings and you will see a new tab called "Vacation"
Installation procedure
----------------------
1) Unzip vacation.tar.gz in plugins/
2) Enable the vacation plugin in config/main.inc.php: $rcmail_config['plugins'] = array('vacation');
3) Open plugins/vacation/config.ini in your editor and change the settings if needed.
4) chown $apache_user plugins/vacation/config.ini
5) chmod 0400 plugins/vacation/config.ini

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
protechzmAuthor Commented:
3) Open the file config.ini in the new folder that was created in step #1  You shouldn't really need to change anything there, but you MUST have the file /usr/bin/vacation on your system for this to work.  If you do not, please do "yum install vacation" to install it (as root)


3) Open plugins/vacation/config.ini in your editor and change the settings if needed.


What Changes am i expected to make here in step 3 if any?
The folder vacation,you are refering to in step 3;  /usr/bin/vacation; is it the usr folder from the root directory??
Please clarify step 3 before i proceed,Am following carefully with your outline,thank you so much,
0
xtermCommented:
The change you would make to config.ini would primarily be the top part under [default] - you have to tell vacation how it can communicate with the IMAP server because the way vacation works is to create a file called a .forward (pronounced "dot forward")  So what happens is that mail comes in and actually forwards to the vacation program, which reads the headers, and constructs and sends an autoresponse which the customer configures.

You can see which drivers are available in README.txt.  You will need to pick one that is appropriate for whatever mail server software you are running.  The default is FTP in which case the vacation program will log in via FTP to your specified mail server using the username and password of the person logged into Roundcube mail, and will upload the .forward file which makes the vacation program work.

As to your 2nd question, yes, /usr/bin/vacation is relative to the / or root folder.  So wherever that file is located on your system, change the path to point there.

Available drivers
------------------
The following drivers are available to do the low level work:
- Sieve. This driver uses ManagedSieve to set/get the Sieve script for sending mail.
- FTP. This driver uploads the .forward file to the user's homedirectory.
- SSHFTP. This driver uses SSH to upload .forward file to the user's homedirectory.
- Setuid. This driver places the .forward file in the user's homedirectory using
the squirrel setuid binary.
- SQL. This driver creates entries in the vacation table in a MySQL database and
modifies the alias table.
At the moment the SQL driver is tailored towards Postfix with either MySQL or PostgreSQL
 but can be modified to suit other configurations.
- None. This driver disables the Vacation tab for hosts that do not support Out of office replies.

Open in new window

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

protechzmAuthor Commented:
Thank you so much,it has worked,Just what i was looking for.
0
protechzmAuthor Commented:
xterm:Am sorry to ask once more,
I have messed up my server and am now setting it up again,i have followed the steps as before but with no luck,i get stuck at number 3. i dont have the /usr/bin/vacation folder; i have tried apt-get install vacation but i seem to loose it somewhere;am now sick not understanding steps 3-5.Please clarify once more,the error i have now is
CONFIGURATION ERROR

Vacation plugin: Cannot connect to the FTP-server 'ubuntu'
Please read the INSTALL instructions!
am thinking its the same path issue /usr/bin/vacation
Any help please;
0
xtermCommented:
Vacation plugin: Cannot connect to the FTP-server 'ubuntu'

It's not the path of vacation, its the fact that you put the FTP server's name as "ubuntu" - that should instead contain the full hostname or the IP address of the FTP server where the vacation plugin will connect to in order to upload the .forward file.
0
protechzmAuthor Commented:
But this same 'ubuntu' is the name of the mail  server ;Do you know where i can make this change?
0
xtermCommented:
Your system needs to be able to resolve it - so maybe it should be 'ubuntu.domain.com', or like I say, just put its IP in there - its in the ini file that you edited.
0
khapbcCommented:
Please help...I have followed these instructions above but I can't figure out which driver to use.
If I leave it at the default driver = "ftp" the vacation tab shows up but I still get the same error (as above). If I leave it as [default] and change driver to sshftp the tab shows up but when I click on it the page is blank.  I have tried so many settings in config.ini and now I am just totally confused.  How do I figure that out? I don't know if this matters but our email addresses have to be fname.lname@host.ca.  I have put the name of our mail server in as well ie. mail.shxxxxx.com and also tried one of our domains mail.xxxx.ca.

Current Error message:
Vacation plugin: Cannot login to FTP-server 'mail.xxxx.ca' with username: kxxx.hxxxx@xxxx.ca
Please read the INSTALL instructions!


Thank You
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.