How can I create a routing loop? It's not working the way I expected...

Greetings, EE.

I'm practicing some routing techniques related to the Implementing Cisco IP Routing class and exam.  I'm trying to manufacture a routing loop in order to correct it with route maps and prefix lists, etc.  I can't seem to get the routing loop to appear the way I thought it would, and I would like a hand.  

Please consider the following topology (linked from Photobucket):

http://i107.photobucket.com/albums/m310/ivaarsen/topolgy.jpg

The lab is intended to feature mutual redistribution at two points, creating a routing loop.  When I redistribute EIGRP into OSPF at R1, for example, R2 gets the routes expected in it's routing table.  R2's next hop is R1 to reach the 192.168.253/254.0 networks (this is expected for now).  When I try to redistribute EIGRP into OSPF at R2 there seems to be no effect.  R1 maintains its routing table - it's as if the redistribution commands at R2 never happened.  If I redistribute in the opposite order (R2 before R1) I have the opposite scenario.

Can someone please tell me what I'm doing wrong?  I have the lab sitting in front of me, so I'll be happy to provide any other details required.  

Thanks for your time.

Eric
ivaarsenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ken BooneNetwork ConsultantCommented:
Well I know when you redistribute into eigrp, if you don't provide the metric i.e.  bandwidth, mtu, reliability etc then it will not redistribute.  I am not sure if the same applies in the opposite direction.  
0
ivaarsenAuthor Commented:
Yes.  I'm executing the same redistribute eigrp <AS> metric <metrics> command on both R1 and R2.  It works on one router but doesn't on the other.  Not sure what's going on.  
0
Ken BooneNetwork ConsultantCommented:
Sometimes you need to clear the routing table to get things going

The command is something like:

clear ip eigrp neighbor ...
clear ip ospf neighbor ...

something like that - to reestablish the the peering.

Also is the iOS the same on both routers?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Nayyar HH (CCIE RS)Network ArchitectCommented:
Try this ...

On R1 and R2, perform mutual redistribution (believe you've done these already) - config below

router ospf x
redis eigrp y subnets

router eigrp y
redis ospf x metric 1 1 255 1 1


On R3 - Remove those two networks from the eigrp process only the two uplinks should be in there - full config below

router eigrp y
no auto
network 192.168.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255
no network 192.168.253.0 0.0.0.255
no network 192.168.254.0 0.0.0.255
redis connected metric 1 1 255 1 1



do a " clear ip ro *" on all RT's prior to verification
0
ivaarsenAuthor Commented:
kenboonejr:

No, they're not the same.  In my lab:

R1:  12.2(8)T5
R2:  12.4(1c)

Running these commands makes the expected routes move from one routing table to another.  For example, if I run clear ip eigrp <AS> neighbor on R1, it gets the routes I expected in its routing table (if it didn't previously have them).  R1 loses them if I run this command on R2.  The exact opposite happens if I run clear ip ospf <#> processes.

nazsky:

Your example config for R3 closely matches mine.  I didn't have metrics specified in my redistribute command, but adding them has no effect.
0
ivaarsenAuthor Commented:
I have a similar topic in Cisco's forums.  I've just shared my configs and routing tables there so I may as well here.  They are as follows:

R1 config:
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ro1
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
 ip address 10.2.7.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.2.1 255.255.255.0
 no fair-queue
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.3.7.1 255.255.255.0
!
router eigrp 5
 redistribute ospf 1 metric 1 1 255 1 300
 network 10.3.7.0 0.0.0.255
 network 192.168.2.0
 no auto-summary
 eigrp log-neighbor-changes
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute eigrp 5 subnets
 network 10.2.7.0 0.0.0.255 area 0
!
ip classless
ip http server
ip pim bidir-enable
!
!
alias exec blank copy flash:blank-config.txt start
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Open in new window

R1's routing table:
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
C       10.3.7.0 is directly connected, Serial0/1
C       10.2.7.0 is directly connected, FastEthernet0/0
O E2 192.168.254.0/24 [110/20] via 10.2.7.2, 00:07:54, FastEthernet0/0
D    192.168.1.0/24 [90/2681856] via 192.168.2.2, 00:12:33, Serial0/0
O E2 192.168.253.0/24 [110/20] via 10.2.7.2, 00:07:54, FastEthernet0/0
C    192.168.2.0/24 is directly connected, Serial0/0

Open in new window

R2's config:
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ro2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.2.7.2 255.255.255.0
 duplex auto
 speed auto
!
<output omitted>
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 10.3.7.2 255.255.255.0
!
interface Serial3/0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial3/1
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Serial3/2
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Serial3/3
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Vlan1
 no ip address
!
router eigrp 5
 redistribute ospf 1 metric 1 1 255 1 300
 network 10.3.7.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 redistribute eigrp 5 subnets
 network 10.2.7.0 0.0.0.255 area 0
!
ip http server
no ip http secure-server
!
ip classless
!
!
!
!
control-plane
!
!
!
!
alias exec blank copy flash:blank-config.txt start
alias exec frame copy flash:FrameSwitch.txt start
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Open in new window

R2's routing table:
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
C       10.3.7.0 is directly connected, Serial2/0
C       10.2.7.0 is directly connected, FastEthernet0/0
D EX 192.168.254.0/24 [170/2560512256] via 192.168.1.2, 00:10:20, Serial3/0
                      [170/2560512256] via 10.3.7.1, 00:10:20, Serial2/0
C    192.168.1.0/24 is directly connected, Serial3/0
D EX 192.168.253.0/24 [170/2560512256] via 192.168.1.2, 00:10:20, Serial3/0
                      [170/2560512256] via 10.3.7.1, 00:10:20, Serial2/0
D    192.168.2.0/24 [90/2681856] via 10.3.7.1, 00:14:54, Serial2/0

Open in new window

R3's config:
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ro4
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
 ip address 192.168.253.1 255.255.255.0
 no keepalive
!
interface Ethernet1
 ip address 192.168.254.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 192.168.2.2 255.255.255.0
 no fair-queue
 clockrate 56000
!
interface Serial1
 ip address 192.168.1.2 255.255.255.0
 clockrate 56000
!
router eigrp 5
 redistribute connected metric 1 1 255 1 300
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Open in new window

R3's routing table:
Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
D       10.3.7.0 [90/2681856] via 192.168.2.1, 00:15:37, Serial0
                 [90/2681856] via 192.168.1.1, 00:15:37, Serial1
D EX    10.2.7.0 [170/2560512256] via 192.168.2.1, 00:15:37, Serial0
                 [170/2560512256] via 192.168.1.1, 00:15:37, Serial1
C    192.168.254.0/24 is directly connected, Ethernet1
C    192.168.1.0/24 is directly connected, Serial1
C    192.168.253.0/24 is directly connected, Ethernet0
C    192.168.2.0/24 is directly connected, Serial0

Open in new window

0
Nayyar HH (CCIE RS)Network ArchitectCommented:
I can see the routing loop already - Follow routing of 253 or 254 networks from R1 you'll see you end up going in circles

Traceroute should also reveal this
0
ivaarsenAuthor Commented:
Yes, this is the point of this lab.  I WANT a routing loop so I can correct it with route-maps, etc.  The problem is that the redistribution command only works for the router where I first issue the command, and the second has no effect, which is the point of this question.  
0
ivaarsenAuthor Commented:
I know it's strange to ask how to break something but, as I've said, the redistribution of routes from EIGRP into OSPF are not behaving as I would have expected.  Do you have any insight on why this may be?

Thanks again.
0
Nayyar HH (CCIE RS)Network ArchitectCommented:
ivaarsen, the title of your post is "How can I create a routing loop?  It's not working the way I expected..."

This leads me to believe your lab simulated routing loop isnt working - Everything is working above as expected even the redistribute command

You're tying two questions into one - A routing exists in the above topology

Why the redis command "isnt" working is another story not one related to the routing loop

Re the redistribution command there are 3 factors that have to be met before redistribution can take place

and one of them is ONLY Routes IN the routing table from the source protocol will be redistributed to the destination protocol. Bearing this in mind you'll see the above network config is working perfectly as configured.

So when redis eigrp to ospf command was first issued on r2 it will exist on r1 routing table (because AD=110 is better that AD=170) this means when you go to configure redis on r1 only redis from ospf to eigrp will seem to work  - anti-clockwise

HTH
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ivaarsenAuthor Commented:
First of I want to thank you for your help.  I don't mean to sound rude in my replies.

Second I apologize for the 'switcheroo' in the content of my question vs. the title.  I'll reword everything and post anew.



0
ivaarsenAuthor Commented:
Wait a second.  I think I understand now.

I expected both R1 and R2 routing tables to match, but being 'mirror images'.  That's not going to happen in this scenario because the 'other' router's routes were replaced with OSPF.  There are no longer EIGRP networks to advertise into OSPF.  The best I end up with using this topology and config is sub-optimal routing going one direction.

My problem was that of metrics.  I wasn't applying all of the parts of the lab, where the distributed routes were being seeded in such a way that the routing protocols were stepping on each other, generating the loop.  I tweaked my configs and I've got a mess of a loop going on now.

Thanks again for your help, I do truly appreciate it.  Points go to you sir for reminding me of things I should know or remember if I'm going to be taking the exam next week.

Take it easy!  -Eric
0
Nayyar HH (CCIE RS)Network ArchitectCommented:
Its the pleasure Eric!

I can see your having fun with the Loops :-) Great stuff!

Good Luck with your exams and Happy Studies!

Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.