Exchange 2010 Multiple Recipients Emails Issue

Since I switched to Exchange 2010 Servers I have a strange issue. It didn't happened on 2003 servers. I have 2 Exchange 2010 SP1 working on DAG mode. We using Symantec Messagelabs to control SPAM and both servers configured as Inbound/Outbound routes on Messagelabs. If a user sending message to large number of recipients it bounces back from Messagelabs with following email:


Subject: Undeliverable: Happy new year! And check out our new website!

Delivery has failed to these recipients or groups:

'xxxxxx@cccccc.com' (xxxxxx@cccccc.com) <mailto:xxxxxx@ccccccc.com>
A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.

.....................................................

'xxxxxx@cccccc.com' (xxxxxx@cccccc.com) <mailto:xxxxxx@ccccccc.com>
A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.

'xxxxxx@cccccc.com' (xxxxxx@cccccc.com) <mailto:xxxxxx@ccccccc.com>
A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.


'xxxxxx@cccccc.com' (xxxxxx@cccccc.com) <mailto:xxxxxx@ccccccc.com>
A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.



xxxxxx@cccccc.com
server-2.tower-203.messagelabs.com #503 MAIL first (#5.5.1) ##

xxxxxx@cccccc.com
server-2.tower-203.messagelabs.com #503 MAIL first (#5.5.1) ##

xxxxxx@cccccc.com
server-2.tower-203.messagelabs.com #503 MAIL first (#5.5.1) ##

xxxxxx@cccccc.com
server-2.tower-203.messagelabs.com #503 MAIL first (#5.5.1) ##

This is only happens when it is more than 50-100 users even limit is 500 on my Exchange servers.
Spoke to Messagelabs and they explaining it to as a some time-out settings on my servers is too low and it cuts the connection to Messagelabs servers and when it is trying to resend the rest of the messages it has no header on it and Messagelabs returning this MAIL first Error.

Any advice? Thank you in advance,
Armen MinasyanDirector of ITAsked:
Who is Participating?
 
bluebookCommented:
Hmm, that gets more interesting then; did any messages get delivered?  Again I'm thinking you should ask for the smtp log, but if the connection was reset before any messages were sent at all it will be hard for them to find it.
0
 
Glen KnightCommented:
Have you tried increasing the idle timeout on the send connector?

See here for details: http://technet.microsoft.com/en-us/library/bb232205.aspx#SendConn
0
 
Armen MinasyanDirector of ITAuthor Commented:
I just changed it from 10 min to 20 min:

>Set-SendConnector "MessageLabs1" -ConnectionInactivityTimeOut 00:20:00

This parameter specifies the maximum time that an open SMTP connection with a destination messaging server can remain idle before the connection is closed. The default value is 10 minutes.

Will test it but let's say it is 500 recipients - can it send this message for so long (10 min)?

Should I change MaxOutboundConnections parameter on Transport server properties?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Glen KnightCommented:
It can't do any harm.

Have you also tried uninstalling the local SPAM software? This will hold it up as well.
0
 
Armen MinasyanDirector of ITAuthor Commented:
I don't do any spam filtering for outbound traffic. Just inbound.
0
 
Glen KnightCommented:
It's the same SMTP engine.  And it could cause interference.
0
 
Armen MinasyanDirector of ITAuthor Commented:
The problem that it is not mater of holding the emails somewhere else. My Exchange getting these emails and pushing them to Outlook clients. But as soon as it arrives to Inbox - it goes right to Recover Deleted Items folder (not Deleted Items). I noticed that it is probably happens only with Outlook in Cashed Mode. If user using just let's say OWA or Outlook on Terminal Session (which cannot be in Offline Cached Mode) than emails flowing normally. But if anywhere on my LAN another Outlook for the same user opened in Cached Mode - it do this weird activity.
0
 
Glen KnightCommented:
Have you disabled the Outlook SPAM engine?
0
 
Armen MinasyanDirector of ITAuthor Commented:
Ignore last email - I posted on wrong topic. Sorry guys.
0
 
bluebookCommented:
I would ask MessageLabs for an SMTP transcript of a session when you get this problem.  If you can tell them the time of day, the sender, subject, a recipient, etc - or the message-id - they should be able to find the smtp log for you (or you may a log yourself?).  That will give some insight into what exactly is happening.  The message implies some kind of sync error between client and server.  If it was a time-out I would expect the whole connection / session to be dropped, whereas this implies that the smtp session is still there, but MessageLabs thinks the current message transaction has completed, whereas Exchange does not.  If you can get the log and post it then we may be able to better understand the issue.
0
 
Armen MinasyanDirector of ITAuthor Commented:
I asked Messagelabs to send me SMTP logs. What's is interesting - if I'm searching for results on their website the only logs they have is the ones what was successfully sent. While speaking to messagelabs I realize something. I have two EXCHANGE 2010 servers. Naming are:
EX2KMBOX
EX2KPRIM
Both are client and hub servers. Both has Send connectors. Here is the log for one of the recipients:

Submitted
12/30/2011 3:14 PM EX2KPRIM
The message was submitted to ex2kmbox
Failed
12/30/2011 5:09 PM ex2kmbox
The message couldn't be delivered.
503 MAIL first (#5.5.1)

So, now I'm thinking it's between my servers. Any ideas?
0
 
Armen MinasyanDirector of ITAuthor Commented:
Outlook SPAM engine? I know I disabled Junk Mail on My Exchange servers. How do I stop SPAM engine for all organization? I do have Messagelabs as my main company SPAM-filter and also have TrendMicro module on my Cisco router - I guess 2 levels is enough.
0
 
Armen MinasyanDirector of ITAuthor Commented:
I'm not sure if this causing the issue. On my Queue Viewer on Exchange I'm seeing following (see the screenshot):
queue viewer
It's saying 451 4.4.0 primary target ip address responded with 451 5.7.3 cannot achieve exchange server. Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

I found this link and did what they recommend.

What else can it be?
0
 
Armen MinasyanDirector of ITAuthor Commented:
Here is the last thing. I was trying to reproduce the issue by sending blank email to almost 100 recipients and here is the error I got on queue viewer:

 queue viewer
421 4.4.2 connection dropped due to connection reset

I guess this is the first step to solution. Anyone know how to fix this?
0
 
bluebookCommented:
What server / next hop does that last error appear against?  It does sound like we have eliminated MessageLabs as a part of the problem, and it is internal between your servers, but if that's the case I don't know how to proceed from here.
0
 
Armen MinasyanDirector of ITAuthor Commented:
Last error 421 4.4.2 connection dropped due to ConnectionReset happened between Messagelabs smart host cluster9out.us.messagelabs.com and my server.
0
 
Armen MinasyanDirector of ITAuthor Commented:
3-4 Users getting message and this is is only what Messagelabs saying they seeing on SMTP log - only 3-4 Recipients! I'm on the phone with them and they ask me to use DNS (MX) records to route mail manualy and that worked fine.
0
 
JackfooCommented:
We had a similar issue with our 2010 server using an outbound smarthost and the DNS (MX) route immediately allowed the email(s) to send.  In our case the outbound smarthost was a Barracuda Spam and Virus Firewall.  By default the SMTP timeout on the barracuda was set to 45 seconds and had been adjusted to 30 seconds previously.  This was causing the email to be stuck in the outbound queue on the exchange server since the SMTP server would time-out before the email(s) could actually be sent.  I increased the time-out on the smarthost which ACTUALLY resolved the issue and allowed us to continue using our preferred smarthost configuration.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.