IE ESC won't turn off

I mistakenly turned on IE ESC for users on one of our 2008R2 servers that is running XenApp 6.5.  When the mistake was realized, I turned it back off through the server manager for both Admins and Users, but users are still getting prompted with the blocked content messages.  Even though it's off for users, it's not really.

Normally, this happening to just one server wouldn't be a huge deal, but this server happens to be source for a vdisk image that we're using to provision to a number of client servers through XenApp Provisioning Servers, so it's really affecting eight of them.

We've done some research and it appears correcting this faux pas has been a pain point for terminal servers for years and there is no clear, easy way to turn off the button that was turned on... that we can see anyway.  Any solutions that don't involve deploying registry edits through Group Policy or resetting Internet Explorer settings for users one by one?  My favorite suggestion to-date came from this KB article (even though it applies to 2003): http://support.microsoft.com/kb/933991... option #1 says "it may be quicker to rebuild the terminal server".  Geez, I hope not.

Your suggestions are appreciated.  Thanks!!
dmansfieldAsked:
Who is Participating?
 
Ayman BakrSenior ConsultantCommented:
Try changing the following registry keys to 1, let the users login then log off and then set them to 0 and let me know if this resolves your issues:

HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\Active Setup\Installed Components\{A509B1A7-37EF-4b3f-8CFC-4F3A74704073}\IsInstalled

HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\Active Setup\Installed Components\{A509B1A8-37EF-4b3f-8CFC-4F3A74704073}\IsInstalled
0
 
Carl WebsterCommented:
Even though you say you don't want to hear it, I always use a GPO to turn off IE ESC.
0
 
Ayman BakrSenior ConsultantCommented:
If you are using a provisioning server then go back to the previous vDisk version which doesn't have this turned on - I am assuming you keep backups of your vDisks for at least the last two prior versions.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
dmansfieldAuthor Commented:
I'm open to that if it's the solution but the GPO experieces we read about didn't solve this particular problem -- when IE ESC was turned 'On' on a terminal server for users by mistake.  Could you please send the configuration you'd suggest and we'll give it a try?
0
 
dmansfieldAuthor Commented:
Thank you for the suggestion of using a backup. I do have that option in my back pocket but because such a long time had passed between the time ESC was turned on until now, I'd rather not roll back if I didn't have to.  We didn't have any users on these servers for an exended period so the issue went unnoticed while other development had taken place.  Good option though... at least it doesn't send me back to a rebuild.
0
 
Ayman BakrSenior ConsultantCommented:
0
 
dmansfieldAuthor Commented:
I loaded the inetesc.adm template and enforced 'disable' in group policy for both users and admins. After applying the policy to the servers, replicating to all DCs, doing a gpupdate /force and a restart, no change; it says its off but i'm still being prompted for users (not for admins though).  
0
 
dmansfieldAuthor Commented:
All that I can get to work is to have the user click the 'reset' button on the advanced tab of their internet explorer settings.  I tried following some suggestions that invovled the default ntuser.dat file, but the fixes found basically had the user browse with the admin IE settings; not really ideal either.  Any other suggestions are welcome.  Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.