Update Dell laptop BIOS without the battery (Dell Inspiron 1564)

Hi,
I have a Dell Inspiron 1564 laptop that I bought a little more than a year ago. May, 2010 more precisely.
A couple of months ago I got this message when hovering the mouse over the battery icon: (connected, not charging). Also, when I turn the laptop on this message appears in a black screen: AC Adapter not recognized, press F1 to continue, F2 for bott options (Not sure about that one) and F3 for something else. I press F1 and the computer works fine, but the "no charging battery still appears.
1 or 2 weeks ago the battery seemed to come back to life for a short time, and I could test it a bit: I could turn the PC on battery only and it would work fine untill the battery depleted. I could (and can) turn it on with the AC adapter only.
The guys at Dell don't seem too sure about what's happening and I still am not sure if the problem is the battery, the AC adapter, the mother board, the BIOS... (I found these options in the internet).
Thus, I am trying to update my BIOS from A08 to A13 or any other that is newer first before moving on to anything else.
Now the big question is: how do I update the BIOS without a charged battery? The system won't let me do that, but I have my adapter plugged in and it is working (seemingly) fine.

Notebook: Dell Inspiron 1564 bought in Brazil (where I live)
Processor: Intel i5
500 GB hard disk, 4GB RAM
Windows 7 SP1
ZbriegnewAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ZShaverCommented:
it really sounds like the battery is dying, since AC works fine

the charging circuit in the battery could be bad maybe

you can get a new battery from hong kong for $30 off of ebay

http://www.ebay.ca/itm/Battery-Dell-Inspiron-14-1464-15-1564-17-1764-JKVC5-05Y4YV-0FH4HR-TRJDK-/230686496369?pt=Laptop_Batteries&hash=item35b5fc9671

I highly doubt a bios update will fix this, but you could always try booting without the battery inserted and see if it lets you update that way
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
andytagonistCommented:
The battery doesn't need to be charged, it just has to be inserted. If the circuitry in the battery is bad, that could present a problem. Check eBay for a replacement battery.

If the motherboard is bad, check with Dell if the system is under warranty. If you're out of warranty, the battery is your best place to start. But since you've spoken to Dell already, you probably know the warranty status. Dell should have also understood why you can't update the BIOS.

If the AC is bad, the laptop would most likely throw up an error at the BIOS load and/or the system wouldn't boot. Nowadays, Dell AC adapters are pretty universal.  Do you know anyone else with a Dell laptop?  Chances are it's the same or a compatible adapter.

Having said all of that, you need the battery plugged in when you attempt to update the BIOS.
I'm not sure if this needs to be pointed out--but put the battery in and plug in the AC adapter when you're updating the BIOS.
0
ZbriegnewAuthor Commented:
My warranty is expired.
Somehow the system recognizes the battery is lower than 10% and it  won't let me update the BIOS. The system says the battery must be over 10% charged.
I've found some people in the Internet who fixed the same problem with a BIOS update.
Maybe I should post another question, but I have a multimeter and I could check the voltage in connector that goes into the laptop and the battery connectors, but I am not sure which pins would how much volts. There are 3 terminals in the connector used by Dell in the adapter and about 6-8 terminal in the battery. Any clues?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ZbriegnewAuthor Commented:
Also, I guess a BIOS update would probably rule out a motherboard problem, but this is more of a hunch.
0
ZShaverCommented:
the voltage of the battery might give you an indication as to how much it is charged but generally lower voltage just means it isn't fully charged
the adapter you could test with the multimeter to see if it is putting out the rated voltage that is printed on the adapter but amperage will very on load
0
nobusCommented:
>>  I could turn the PC on battery only and it would work fine   <<  how long?  if very short, it is a bad battery
i would not start a bios update with a bad battery; first have this corrected
0
MarkCommented:
This is a common issue caused by a wire in the AC adapter cord being severed. The barrel plug on the end has 3 connection points, the center pin being a sensor wire which identifies the ac adapter as a dell model. When communication between the motherboard and the AC adapter is interrupted you get the message you are seeing. The center wire connected to the barrel plug is the sensor wire. You need to either buy a new AC adapter or find the break in the wire(usually at the barrel plug) and resolder it.
0
ZbriegnewAuthor Commented:
Sparkmarker,
It makes a whole lotta sense what you just said, but do you happen to know if I can be sure of that by measuring the output voltage in the battery compartment in the bakc of the notebook with a mutimeter? It has 9 pins, and I really don't know which pins I should measure.
IMGP0361.JPG
0
ZbriegnewAuthor Commented:
I just bought a new AC adapter, tested it in the store and it worked for some minutes. I still have to test it more carefully at home.
Now I want to understand exactly what's going on here. How come the generic adapter seems to be working fine if this is a proprietary Dell technology? In fact I am assuming this as true. Not sure if it really is.
0
andytagonistCommented:
"proprietary Dell technology"...don't ask no questions and I won't tell you no lies...  :)
And you should have tested in the store that the battery is charging--even 1% is enough to prove the point to you. Just because the charger powers the laptop doesn't tell you if the battery will charge...

Let us know how it works and if the battery charges.
0
ZbriegnewAuthor Commented:
I just plugged my new AC adapter some 10-15 minutes ago and the battery icon in the system tray says it has already 6% of the total charge. Well, it looks like it was the adapter. But then, do Dell notebooks have a special circuitry that detecs their chargers, or some generic ones? This may be a dumb question, but a new idea just came to my mind: as the male connector has 3 connection points, i.e. A, B and C, maybe, say, points A and B feed the laptop with electricity while points B and C feed the battery. Am I right this time?

BTW, 14% of the battery is full as I finish this post.
0
ZbriegnewAuthor Commented:
I also got to update my BIOS from A8 to A13, but only with the new adapter. The system would not let me do that with the battery under 10% of its power, and I could not find any workaround to update the BIOS with less than 10% of the battery, which was the original question...
0
MarkCommented:
Measuring the voltage probably wouldn't  do much good as voltage alone is not indicative of a good battery. It has to be measured under load and that means you need something to be powered by it when it is checked, not something for the normal user to be doing.
If you are comfortable with trying a repair on the old adapter, you can still check the connections on the old Ac adapters barrel plug by cutting the wire about 4-5 inches from the barrel plug and use a multitester on OHMs to check each wire. DO THIS TESTING UNPLUGGED FROM  POWER.The center pin is the center white wire , the inner part of the barrel is the  wire surrounding the center white wire, the outside of the barrel plug is the outer ground wire.
0
nobusCommented:
the best way to test a battery is to charge it ful  - then measure the time it takes to drain
0
andytagonistCommented:
It's an after market charger--it's perfectly fine to use as long as it works for you.

Can you flash the BIOS now?
0
ZbriegnewAuthor Commented:
I came back here so that the whole story gets registered. After a week using the new adapter, it just stopped charging the battery. I can use the laptop with the charger plugged in, but now a new symptom appeared: now I cannot turn on the notebook with the battery connected, and, whenever it is working with the adapter plugged in, if I put the battery in its compartment, the notebook turns itself off.
I called Dell and they told me they are going to call within the next days to make some analysys and diagnostics.
By my researches in the Internet, I believe, in fact, the motherboard is to blame this time and it's going to cost a lot of money to have it changed. I expected more from a brand like Dell.

BTW, I did flash my BIOS from A8 to A13.
0
ZShaverCommented:
honestly i see this all the time and it totally sounds like a dead battery, don't jump to replacing the whole board without at least trying another new battery which is what i suggested as the first reply to this thread. generally with a dying battery you see it either not holding a charge or not charging fully, exactly as you described initially. then the battery holds no charge (current situation) and sometimes will not allow the system to boot when present (current situation), but the system generally always boot with just the a/c present and no battery.

this isn't just "oh i saw this on my laptop and one other dude's laptop", i've seen batteries dying like this on literally hundreds of laptops of all makes and models

i've never heard of anybody going through as nearly much trouble as you (multimeters, dell tech support, new a/c adapter, bios flash) without simply trying a new battery.  is there a reason why you are purposely ignoring this crucial troubleshooting step?

you expect more from dell? i'm sure they expect more from you too...
0
MarkCommented:
Has the ->AC Adapter not recognized<- issue gone with the new adapter?
It sounds as if you have 2 problems at the same time. Obviously the ->AC Adapter not recognized<- was due to a failure of either the sensor wire broken, or the sensor chip in the adapter failing.
It also sounds like you have  a failing battery as well, giving symptoms of non starting or shutting down when inserted.
Bad batteries can do weird things,and having 2 components fail at the same time can certainly confuse issues.

0
nobusCommented:
and also not - if the adapter is not recognised, the battery will never charge
0
ZbriegnewAuthor Commented:
Ok, guys, thank you all for all the help you've been giving me so far!

ZShaver: I kind of understand your frustration. I am very frustrated too. I would have already tested my notebook with another battery if only I had found one. I have tried 3 stores and none had Dell batteries in stock. I would have to buy a new one and I don't want spend money without being sure of what's going on. Also, I have a curious mind and I am trying to learn something new here.
As for your comment, "Dell expects more from me", it couldn't be more pointless. My previous notebook was a Toshiba, which I used for 3-4 years without having a single problem. And I would still be using it if it weren't for the high costs and difficulty of finding a new motherboard. I expected at least the same from a Dell notebook. Anyway, I still would like to count on you expertise here.

sparkmaker: I must confess that I just forgot to check if the "AC adapter not recognized" went away with the new adapter, as the notebook was working apparently fine. Sorry, my bad!
I believe you are right; it seems 2 problems appeared with a week difference.

More facts:

1 - I have been to the store where I bought the generic AC adapter today and tested the notebook with yet a third charger and... same problem.

2 - I have also managed to measure the output voltage in the original AC adapter and found this:
•      19,6 Volts between the external and internal rings in the PA12 connector and 0 V between the internal ring and pin-like central prong, which means (if I am not wrong) that the first adapter is really defective.
•      As for the second, generic adapter, I measured 19,2 V between the external and internal rings and 19,2 V between the internal ring and the central pin-like prong, which means that adapter 2 is working fine.

3 – I guess that, as adapter 2 worked fine for one whole week, a second problem emerged from the darkness and the problem lies with the motherboard or the battery, being the latter more likely. I will keep on trying to find a spare battery to test. Note: batteries are a bit expensive here in Brazil, where I live, so I will not buy a new one until I am sure it also is defective now.

Question: do you guys agree with me, that 0 V between the internal ring and the central prong means a defective PA12/adapter?
0
nobusCommented:
well  - it depends on the configuration of the plug, most have voltage between outer and inner contact  -but i believe Dell has some proprietary models
0
nobusCommented:
but on this picture, i see only one outer connection?   http://www.chargerbuy.com/replacement-dell-inspiron-1564-ac-adapter-19-5v-4-62a.html
can you post a pic of yours?
0
MarkCommented:
I would still investigate the old adapter and the possibility that the central wire is broken. This is easily fixed if you have soldering skills.
0
ZbriegnewAuthor Commented:
sparkmaker, the old adapter really seems to be damaged as the voltage between the central pin and the internal ring reads 0 (zero). I guess I'm going to try to solder it but I will have to learn how to open the connector. The soldering itself doesn't seem to be the biggest problem.

nobus: my connector is exactly like the one in the link you posted. It is a PA12 and it has something like an internal ring/collar, an external ring/collar and a pin (which they call smart pin in the link). Picture of my PA12 connector
0
nobusCommented:
i never noticed an inner ring - but i can be wrong..
0
ZbriegnewAuthor Commented:
This is not really an inactive question. I am still trying to find a battery I can borrow to test my notebook. I guess it would be easier if only I had bought an Inspiron 1525...
0
MarkCommented:
To open the connector just cut it along the length. You will need to use shrink tubing to cover the wires again as the cover will be destroyed as it is molded around the wires.
0
andrewmccCommented:
Hi, had this Dell charger and battery issue across several laptop models from Dell.
Found some interesting points - @ Nobus, you might find this interesting :)

Had a client I recommended buying Dell laptops for the sales team, (they wanted to have "cool looking" laptops, so bought the Dell XPS M1530.
About a year and a half later, they rang to say that the battery was not holding the charge, as most of the team are field based, I asked them to either borrow another charger and test a working laptop with decent battery with confirmed operational charger then swap with the suspect dodgy battery so the first guy could have his laptop (he needed a working battery), so off we went and swapped the battery, guess what!

The original laptop did something with the second battery.... that started saying at BIOS post, battery needs replacing, etc as above.

Took me about three or four months before I got to the bottom of it for the XPS M1530 problem as the team were spread over the UK.

Turns out, some of the BIOS revisions for Dell laptops seem to format the battery to each system, as much as I can guess, as we swapped chargers, batteries, etc in different combinations to get to the bottom of it.

Finally, I came across the Area Manager's laptop - same M1530 about three years old with dodgy battery etc, his fiance had lost her laptop and wanted one like his (ended up sourcing one from a Dell refurb outfit in Manchester, UK) I had been given a similar model XPS M1530, it had a different BIOS revision, had a working battery!
Plus whichever battery I plugged in, charged to 100% and worked fine.
So it was not any of the batteries, or chargers, (we had one which did get chewed up by a dog so that did not count).

I checked online, thinking better use the latest BIOS revision, tried that and found battery problem, not charging.

Somehow, the BIOS update which was the latest one, or even an older A05/ A06 / A07 for that model still seems to have caused some issue with batteries and charging.

When I searched on the Dell forums, it mentioned that in order to do a BIOS update (or downgrade) the battery has to have a reported minimum 50% charge, so I ended up downgrading each laptop to the one listed, think it was A11 (not A12 - was the latest one), low and behold with his fiance's working laptop, I used that to charge the other batteries, in turn either downgrading or upgrading to the specific BIOS revision, and wow, each laptop now works fine with the original battery and original charger with no issue.

I know this does not apply to everyone, luckily I came across an identical model so I could borrow the battery to sort the BIOS revisions, though at the same time I became aware that damage or a very loose connection from the charger adapter pack to the laptop can cause issues, the XPS M1530 has a known issue with the mobile version of the Nvidia video card overheating on the motherboard, Dell will only swap it out under warranty.
0
ZbriegnewAuthor Commented:
I still haven't bought a new battery, but I am using my laptop on the AC adaptor. The fact of the matter is that what seems to have happened is: the battery died out completely; it worked again for some weird reason for some time when I used a new AC adaptor, but died definetely and unreversebly shortly after that.
Thanks to everyone that helped and/or tried to help me with this pain in the neck trouble.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.