SBS 2003 to 2011 forced demote problems

I have recently migrated from SBS 2003 to 2011. Had I seen this day, I would have done a clean install and manual account migration for sure!!

In any case, due some hickups I ended up with USN Rollback and from that point on I was on my own to finish the rest of the migration manually. I reviewed all the information I could find and it seemed like there was a way of demoting my old server and cleaning up the forest on the new server manually and cleaning up DNS, GPOs, etc. which I followed. (Source 1, Source 2) I also uninstalled Exchange 2003 before demoting.

But it seems like that was not enough, my new SBS 2011 is showing to be in a very unstable state. At certain hours in the day I start getting numerous errors logged, the ones related to AD are Evend ID 4 Source: Security-Kerberos (3 or 4 of these for some computer accounts), each followed by 10 to 15 DCOM errors (Event ID 10009 Source: DistributedCOM) for other computer accounts in the AD. According to this KB (http://technet.microsoft.com/en-us/library/cc733987(WS.10).aspx) I have to remove the computer accounts from the old forest, but the problem is I don't see any computer accounts that are not in use! And sometimes a whole bunch of other DCOM errors (Event ID: 10016 Source: DistributedCOM).

On the Exchange sides the only issue is that the old "First Administrative Group" is still sitting somewhere, but I don't know where, in fact when I run the EXBPA I get a "Site Folder Deleted" error that points me to this KB (http://technet.microsoft.com/en-us/library/aa996485(EXCHG.80).aspx) which indicated the resolution to be the deletion of the group from ADSI Edit. But amazingly enough I don't even see the "CN=Services" sub-tree in there!! (See Attached Image).

2 days ago, I ran some Windows Updates on the SBS 2011, including one for Microsoft Office SharePoint Foundation 2010 (KB 2494001) that required me to run a script afterwards. Ever since that update SBS reboots itself twice a day (8 or 9 am and 7 pm) after some "critical" SharePoint Foundation errors (Event ID: 6398 and 3760) appear in the log. At first it seemed like it was it was the Customer Experience Improvement Program (CEIP) which I disabled following this KB (http://support.microsoft.com/kb/2616940), but it is still happening.

I am almost ready to roll out a clean install of SBS 2011 and just migrate everything manually, but wanted to see if anyone has experienced and possibly survived a similar situation!

I should note that besides the reboots, everything from the user's perspective works fine.

 ADSI Snapshot
iman98Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SuperTacoCommented:
here's a link that helped me solve the same sharepoint issues

http://technet.microsoft.com/en-us/library/cc561011(office.12).aspx

http://technet.microsoft.com/en-us/library/cc561036(office.12).aspx

AS for your other errors, try disabling IPv6 if you are not using it on your network
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
iman98Author Commented:
The first linked helped a lot, thank you. Now if I can resolve the Exchange server issue, I can keep things running smoothly!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.