Remote Desktop

Hello,

I try to make remote desktop for windows 2008 thru modem Linksys WRT160n
I did :
1- I opened single port forwarding 3389 in the mode
2- I enabled remote desktop in the windows server 2008
Do I miss some thing?
Thanks
samprgAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ZShaverCommented:
forward port 3389 as TCP to the right internal IP address (static)
if there is any firewall software on the server you need to open up port 3389 in that aswell
0
Brad HoweDevOps ManagerCommented:

1. Did you set a Forward rule to send the requests to your internal.server.ip over port 3389.
  eg: http://portforward.com/english/routers/port_forwarding/Linksys/WRT160N/Remote_Desktop.htm

2.  Enable remote desktop
  eg: http://technet.microsoft.com/en-us/library/cc794832(WS.10).aspx

3. Do you have the firewall enabled to allow Remote Desktop enabled on the host?

If i had to guess the security context is still set to high.

let us know,
-Hades666
0
andytagonistCommented:
Make sure RDC is enabled and you have an account with permissions to connect with it.
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

samprgAuthor Commented:
ZShaver:
I do not have any firewall software on the server
hades666:
1,2,3 I did
0
Brad HoweDevOps ManagerCommented:
From your client pc attempt the following.

1. Open CMD
2. Type "telnet your.ip.addr 3389"

Black screen Firewall openned.

Connection failed, your port forwarding or firewall is dening it.

Let us know,
Hades666
0
ZShaverCommented:
Not all routers will support port forwarding from within the network to within the network

You may have to test this from another network, or give us the IP and we'll see if we get an RDP connect screen.
0
ZShaverCommented:
if you don't want your IP posted here you can email it to me and I'll try it rimtech@gmail.com
0
samprgAuthor Commented:
From a client pc Windows 7, I got
'telnet' is not recognized as an internal or external command,
operable program or batch file.
0
Brad HoweDevOps ManagerCommented:
lol, Telnet Client is not installed by default on Windows 7.

Install Telnet Client on Windows 7 or Windows Vista


On Windows 7, Windows Vista, you can use the Windows Features tool to install optional components.

To install Telnet Client on Windows 7 or Windows Vista

1.Click Start, and then click Control Panel.

2.On the Control Panel Home page, click Programs.

3.In the Programs and Features section, click Turn Windows features on or off.

4. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
5. In the Windows Features list, select Telnet Client, and then click OK.


Also, can you respond to the following:

1. where is this PC located?
2. Where is the client located?


Thanks,
Hades666
0
samprgAuthor Commented:
ZShaver:
I use the router Linksys WRT160n, I also tested from outside is same thing, and I didn't get an RDP connect screen.
0
samprgAuthor Commented:
hades666:
I got
Connecting To My.ip:3389...Could not open connection to the host, on por
t 23: Connect failed
Note:I tested it from same network and from home
0
Brad HoweDevOps ManagerCommented:
Great, so if you are getting connection failed from an internal source and and home Source, the issue is with your server setup.

Are you sure you have disabled ALL windows firewall profiles (domain,private and public) temporarily.

If you attempt to RDP to the server ifself from itself, You should get a login prompt but give an error that you cannot login to a logged in server.

As well, you Remote desktop settings, Are they enabled for allow all clients or only secure with NLA.

Let us know,
Hades666
0
ZShaverCommented:
you used the wrong telnet syntax
it's not colon port, it's space port

e.g.
you need to use
telnet hostname port
not
telnet hostname:port
0
ZShaverCommented:
which is why it said it connected on port 23...
0
samprgAuthor Commented:
ZShaver:
I got
C:\Users\W7>telnet My ip 3389
Connecting To my ip...Could not open connection to the host, on port 338
9: Connect failed
0
Brad HoweDevOps ManagerCommented:
You still have not tried to RDP from the server itself to itself using it;s LOCAL IP address.

Please confirm this works.

Thanks,
Hades666
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
samprgAuthor Commented:
hades666:
I didn't have try to RDP from the server itself, I try to RDP from other computers (mine and my friend outside)
0
Brad HoweDevOps ManagerCommented:
Try it from itself. I want to see if you actually set it up correctly.

Thanks, Hades666
0
samprgAuthor Commented:
hades666:
Good idea.
Yes, I have tried now  from other compuer by local IP and it works fine
0
Brad HoweDevOps ManagerCommented:
So RDP from a PC on the same network by local.ip.addr works.

If that is the case, your Port forwarding is the issue at the moment.

-Hades666
0
samprgAuthor Commented:
I willt leave to test in other network,
0
ZShaverCommented:
You should double check your port forwarding. You might want to try enabling DMZ to the server to forward all ports and see if that makes a difference.

Also, is there only 1 router involved? E.g.  Cable Modem presenting public IP -> Router -> Hosts

If you have multiple routers you would have to forward the port on the outer router to the inner router and then from the inner router to your host.
0
samprgAuthor Commented:
I guessed it,  I have tested the server and router at my home are work.
So I think, it's building network security
Thanks guys for help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.