Links not working

Hi Experts,

Please visit the following URL:

http://www.iwatchnetwork.eu/alphabet/

You will see an A-Z list of alphabet links running across the page. When you click one of the letters you will be taken to this point in the page. This has stopped working for me in Firefox but still works in I.E. and Chrome. Does anyone have a suggestion as to why?
DColinAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

scherrer_coCommented:
Hello, a Firefox security setting may have inadvertently been changed. You can ensure that you are using the most up to date version of Firefox by going to Help - About Firefox and make sure that it shows at least version 9.01. If you have an up to date version of Firefox I can explain how to restore its settings.

Thanks
0
greyknight17Commented:
I would check to see if you have any Firefox add-ons/extensions installed that may be blocking the script from running. For example, I personally use NoScripts to block all scripts for webpages. I just visited that website you posted and have the same problem. Once I allowed scripts to run on the page, I was able to access those specific sections.
0
Dave BaldwinFixer of ProblemsCommented:
It's probably blocking that pop-under that you have on that page.  That's not a nice thing to do.
0
CompTIA Security+

Learn the essential functions of CompTIA Security+, which establishes the core knowledge required of any cybersecurity role and leads professionals into intermediate-level cybersecurity jobs.

DColinAuthor Commented:
scherrer_co:

I now have 9.01
0
scherrer_coCommented:
Are you still having that issue? You can check for add-ons as greyknight suggested by going to Tools - Add-ons. Most extensions should not affect this, but some add-ons/extensions have the potential to block the script.
0
DColinAuthor Commented:
scherrer_co:

It was working OK until about a week ago then stopped. I get the pop under advert but not a move to the required alphabet character.
0
scherrer_coCommented:
Have you customized Firefox in any way that restoring it to default settings would be a problem?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
d4durveshCommented:
its working properly on my all three browsers. Firefox too.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.