Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Adding godaddy cert. to SBS 2011 - "The specified port (443) is being used by a different binding

Posted on 2012-01-17
6
Medium Priority
?
1,963 Views
Last Modified: 2013-04-09
Hi all,

When installing a GoDaddy security cert. in SBS 2011 and following their instructions below:

I receive the warning during step #11 saying "The Specified port (443) is being used by a different binding"

Also at step #8 I used "default Website. Is this correct since all I really need to secure is remote logins to for RWW?

To Install SSL Certificates

   1. From the Start menu, select Control Panel, and then select Administrative Tools.
   2. Select Internet Information Services Manager, and click Server Name.
   3. In the Security section, double-click Server Certificates.
   4. From the Actions menu, select Complete Certificate Request...
   5. In the Complete Certificate Request Wizard, enter the location for the certificate file. The file extension might be .txt or .crt instead of .cer (search for all files).
   6. Enter a friendly name for the certificate file, and then click OK.
   7. After the certificate installs, assign it to the correct website in IIS. In the Internet Information Services Manager window, from the Connections menu, select the name of the server where you installed the certificate.
   8. For Sites, select the site to be secured with the SSL certificate.
   9. From the Actions menu, select Bindings...
  10. In the Site Bindings window, click Add...
  11. In the Add Site Binding window:
          * From the Type drop-down menu, select https.
          * From the IP address drop-down menu, select All Unassigned or the IP address of  the        site.
          * For Port, type 443.
  12. From the SSL Certificate drop-down menu, select the SSL certificate you just installed, and then click OK.




Thanks,
Frank
0
Comment
Question by:flteng562
  • 3
  • 2
6 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37451575
Don't use IIS to install a certificate - use Exchange Wizard to request it, then the Wizard to install it.  Their instructions are wrong!

The wizard is under Exchange Management Console> Server Config.
0
 
LVL 60

Expert Comment

by:Cliff Galiher
ID: 37451577
Ignore the GoDaddy instructions. With SBS, *always* use the wizards. The GoDaddy instructions are written for a standalone server that only has IIS. SBS has IIS, Exchange, and RDGateway, which all require the certificate.

Use the "Add Trusted Certificate" wizard in the SBS console to install the certificate, and only use the GoDaddy instructions to install the "intermediate" package (which will not involve IIS or bindings) and you won't have problems.

-Cliff
0
 

Author Comment

by:flteng562
ID: 37451636
Hi cgaliher,

I did use the godaddy instructions to install the intermediate cert. I stopped at the bindings error message and then used the "Add a Trusted Certificate Wizard the install the cert. The wizard was very quick.

Is there a way I can test this out on the server?

Frank
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
LVL 60

Accepted Solution

by:
Cliff Galiher earned 2000 total points
ID: 37451722
As long as you've stuck to the wizards, you should be able to browse to remote.yourdomain.com from any machine *inside* the network and view the website and the certificate. The wizards set up a split-brain DNS configuration by default, so this will work even if you have not yet configured your firewall.

-Cliff
0
 

Author Comment

by:flteng562
ID: 37451767
Hi Cliff,

Thanks for the help with this. i am doing doing most of the prep work offsite then will be setting  up the server on Saturday. I don't think the cert. will be a problem. I have to get back into the SBS way  (Wizards) of doing things. My last 3 server install have been 2008 standard.

Thanks again,

Frank
0
 

Author Closing Comment

by:flteng562
ID: 37451769
Thanks again
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Integration Management Part 2
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…

782 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question