"An unexpected error has occurred" -- SharePoint 2010

Again, I've come across this annoying error (that gives you no clue to what's wrong). This time it occurs when I'm trying to access "Site Permissions" on a particular site in my site collection. Not all sites, just this one. I've searched all over for answers but have not found any solutions. I've also tried to access the role.aspx page directly and receive the same error. Oh, the error is "An unexpected error has occurred" if you did not see in the title. I did move this sub-site from one site to another (not site collection). All are under the same collection. I have moved many sites around as we have been restructuring our SharePoint site. May have issues with other sites but this is the one I've noticed and need to fix to adjust the permissions. A user needs access and I can't give it to them.

I appreciated all ideas and feedback.

Thanks.
Sean
LVL 1
caimisAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

milindsaraswalaCommented:
Paste your ULS Log
caimisAuthor Commented:
I'm not going to paste my entire log for all to see. Here is the error message from the log that correlates with the error I get on the screen. Let me know if you need more info. If you need to see more of the log, then give me an email address and I will email it to you.

Thanks.
Sean

SPError.docx
Justin SmithSr. System EngineerCommented:
Does this site have unique permissions?  Might need to use PowerShell to set it to "inherit" from the top level site.  If this is an option, I'll reply with the commands.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

caimisAuthor Commented:
Yes, it has unique permissions. So, resetting them to inherit is not optimal but I will give it a try to get by this issue. I have the old server that shows the permissions that I can mimic. What is the powershell command(s) to attempt this?

Thanks.
Sean
Justin SmithSr. System EngineerCommented:
$web=get-spweb http://urlofthesubsite
$web.ResetRoleInheritance()
$web.update()

See if that gains you access to the permissions page.  If so, you can then break inheratence and reset the permissions.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
caimisAuthor Commented:
This worked, as a work around. Not the optimal way to fix but I guess it gets the job done. It would be nice to not have to do this if I run across it some more.

Thanks for your help ACH1LLES.

Sean
caimisAuthor Commented:
Got the job done, but more of a work around than a fix.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.