troubleshooting Question

USB ports from ThinStation to Windows 2008 R2 TS

Avatar of Zhunya
Zhunya asked on
LinuxSoftwareWindows Server 2008
2 Comments1 Solution1097 ViewsLast Modified:
Need a working USBIP package on Thinstation2.2.2i to redirect client ports to an MS Terminal Server
 
I took compiled one from itadvisor.ru - but it did'nt work. It says that
usbip.ko, usbip_common_mod.ko, vhci_hcd.ko, shuld be loaded first. The log says
that insmod can't insert them because these modules have an invalid format. The
format of them is realy invalid, as they were compiled for a 2.6.17 kernel, but
mine is 2.6.16.5.
 
I tried to compile it from sources - but it all stops at ./configure. The error
it shows is something like /usr/include/sysfs/libsysfs.h not found. By the way
the same error i saw in any versions of usbip source compilation.
 
I tried to use the rpm utility in the chroot environment - did'nt work too. So i
placed the libsysfs.h from the rpms manualy in the corresponding directories -
but it seems not to work. In that case it says
 
checking for sysfs/libsysfs.h... yes
checking for sysfs_open_directory_list in -lsysfs... no
configure: error: Missing sysfs2 library!
 
Anyone knows how this is fixed? I'm trying to solve it, but no luck.
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 2 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 2 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros