We help IT Professionals succeed at work.

Wireless connection on OSX 10.6

Bellscape
Bellscape asked
on
460 Views
Last Modified: 2012-04-15
Just wondering if anyone knows the cause of the following issue.

Wireless connection setup on an Netcomm NB9WMAXX modem/router (WPA-PSK).  Macbook running OSX 10.6 connected to Wireless.  Once Macbook is restarted the SSID is shown under Devices in the Airport status windows at the top right of finder, and wont connect.

If trying to connect to the wireless network it asks for a username/password(not the Mac username/password) but thinks its an 802.1x network.

Changing SSID or factory resetting modem work until restart when network gets listed under devices again.

I have deleted all networks from the settings and removed all saved wireless info from the Keychain app but after reboot the wireless connection flips back to a 802.1x network and is listed under devices.

I have tried 2 different wireless modems and they work fine.

At one point the airport logo at the top right showed the airport symbol with a computer screen in the middle of it but I dont know what this means(possible thinks its an adhoc network or something).

If anyone has any ideas let me know - I just used a different modem but there was obviously a setting on the Mac which linked the MAC address of the modem with something
Comment
Watch Question

CERTIFIED EXPERT

Commented:
The first thing to try is, if you are allowed to do this in your environment, to remove the WPA encryption. Make sure there are no other issues getting the Mac to connect to the wireless network.

Assuming that works OK, put back the WPA encryption, making sure to choose TKIP not AES if you have the choice. Then edit the wireless connection on the MAC, putting in your WPA password and see if that doesn't do the trick.

Author

Commented:
Nope, i tried WPA2, WPA and no encryption - same issue after restart with all
CERTIFIED EXPERT

Commented:
The icon you are seeing does mean that it thinks that it's attached to an Ad Hoc network: see

http://support.apple.com/kb/HT3821

My suspicion is that something in the way the modem/router is configured is the issue.  I've looked over a PDF on setting the router up and for the most part it appears fairly simple and not a 1-off setup.  Still you might play with the settings.

BTW, if the Mac sees an AD HOC wireless setup, that is not compatible with WPA or WPA2.

Author

Commented:
Yep thats the icon.

My question is how do you stop the iMac from thinking its an Adhoc network.  I have tried changing SSID, Encryption settings(WPA, WPA2, No Encryption).  I have also factory reset modem and it still thinks its an adhoc network.  It must connect via MAC address somehow.

Theses settings must be save somewhere
CERTIFIED EXPERT

Commented:
I'm not sure. I have done wireless setups on a number of Macs with differing versions of OS X without ever seeing this. Have you fully checked the airport setup on the Mac to see if anything there gives you a clue?

Could there be another wireless network that you don't know about that could be Ad Hoc with the same SSID; I know that it's a long shot, but I can't imagine that the Mac would classify something as Ad Hoc that wasn't.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
reason
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.