troubleshooting Question

Unable to connect to existing Ultralite database in Iphone using IOS SDK

Avatar of Murugesh Perumal
Murugesh PerumalFlag for India asked on
Mac OS XiOSiPhoneObjective-C Programming
1 Comment1 Solution1613 ViewsLast Modified:
Hi,
  I have created an Ultralite db sample Iphone App using Xcode 4.2, Apple IOS SDK 5.0, Objective C and SQL Anywhere 12 version. I am trying to connect the ultralite db in my app. I created 'libulrt.a' file for the simulator and armV6 and armV7 processors. The app connects to the db and retrieves the data when I run it in the simulator.

If I run the same app in the Iphone device, it does not work. It throws the error sqlcode = -954.
–954  The database '%1' was not found

I copied the ultralite dub file into 'Resources' folder of my app. I have written the code to copy this db from the App path to the Documents directory. The database gets copied to Documents directory but unable to connect to this db.

FYI: The Ultralite db has been created using Sybase SQL Anywhere 12 version with Ultralite 12.0.1.3152

The below 2 links will give more information of what we are trying it out.

¿      http://sqlanywhere-forum.sybase.com/questions/8696/need-a-working-example-for-iphone
¿      http://dcx.sybase.com/1200/en/ulc/ulc-iphone-tutorial.html


Is there any solution to come out of this problem? It is blocking my project research and development.
ASKER CERTIFIED SOLUTION
Murugesh Perumal
Sr.System Engineer

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 1 Comment.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 1 Comment.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros