troubleshooting Question

Ruby on Rails installation fail on OS X Lion

Avatar of max7
max7 asked on
Web Languages and StandardsMySQL ServerRuby
20 Comments1 Solution4121 ViewsLast Modified:
Greetings,

I've installed Ruby and Rails on OS X Lion and I've got a few problems that make me wonder if I shouldn't just start over again (trouble is, not sure how I would *start over*).

I'm running ruby 1.8.7 (2010-01-10 patchlevel 249) [universal-darwin11.0]

Here is a list of gems installed:

*** LOCAL GEMS ***

aasm (3.0.2, 2.2.0)
abstract (1.0.0)
actionmailer (3.2.1, 2.3.14)
actionpack (3.2.1, 2.3.14)
activemodel (3.2.1)
activerecord (3.2.1, 2.3.14)
activeresource (3.2.1, 2.3.14)
activesupport (3.2.1, 2.3.14)
addressable (2.2.6)
after_commit (1.0.10)
airbrake (3.0.9, 3.0)
akami (1.0.0)
archive-tar-minitar (0.5.2)
arel (3.0.0)
Ascii85 (1.0.1)
authlogic (3.1.0, 2.1.1)
awesome_nested_set (2.1.2, 1.4.4)
aws-s3 (0.6.2)
bluecloth (2.2.0, 2.1.0)
braintree (2.13.4, 2.13.1)
bson (1.5.2, 1.5.1)
bson_ext (1.5.2, 1.5.1)
builder (3.0.0)
bundler (1.0.22)
childprocess (0.3.1)
columnize (0.3.6, 0.3.5)
crack (0.3.1, 0.1.8)
cucumber (1.1.4, 1.1.3)
daemons (1.1.8, 1.1.4)
diff-lcs (1.1.3)
email_spec (1.2.1, 0.6.5)
erubis (2.7.0, 2.6.6)
ezcrypto (0.7.2)
factory_girl (2.5.2, 2.3.2)
faraday (0.7.6, 0.7.5)
ffi (1.0.11, 0.6.3)
forgery (0.5.0)
gdata (1.1.2)
geokit (1.6.5, 1.6.0)
gherkin (2.7.7, 2.6.8)
glennfu-faster_csv (1.5.5.1)
gyoku (0.4.4)
haddock (0.2.2)
haml (3.1.4, 3.1.2)
hike (1.2.1)
hoe (2.13.1, 2.12.4)
hpricot (0.8.6, 0.8.4)
httparty (0.8.1, 0.7.8)
httpi (0.9.5)
i18n (0.6.0, 0.4.2)
icalendar (1.1.6)
journey (1.0.1)
json (1.6.5, 1.5.4, 1.4.6)
kgio (2.7.2, 2.0.0)
koala (1.3.0, 1.2.1)
linecache (0.46, 0.43)
log4r (1.1.10)
macaddr (1.5.0)
mail (2.4.1)
mario (0.1.3, 0.0.6)
metaclass (0.0.1)
mime-types (1.17.2)
mocha (0.10.4, 0.10.0)
mongo (1.5.2, 1.3.1)
multi_json (1.0.4)
multi_xml (0.4.1)
multipart-post (1.1.4)
mutter (0.5.3)
mysql (2.8.1)
mysql2 (0.3.11, 0.2.17, 0.2.7)
net-scp (1.0.4)
net-sftp (2.0.5)
net-ssh (2.3.0, 2.2.2, 2.0.24)
newrelic_rpm (3.3.1, 3.3.0)
nokogiri (1.5.0, 1.4.7)
nori (1.0.2)
pdf-reader (1.0.0, 0.10.1)
polyglot (0.3.3)
rack (1.4.1, 1.1.2)
rack-cache (1.1, 1.0.2)
rack-protection (1.2.0)
rack-ssl (1.3.2)
rack-test (0.6.1)
rails (3.2.1, 2.3.14)
railties (3.2.1)
raindrops (0.8.0)
rake (0.9.2.2, 0.8.7)
rbx-require-relative (0.0.5)
rdoc (3.12, 3.9.2)
redis (2.2.2)
redis-namespace (1.1.0, 1.0.3)
resque (1.19.0)
resque-lock (1.0.0)
ri_cal (0.8.8)
riddle (1.5.1, 1.4.0)
right_aws (3.0.0, 2.1.0)
right_http_connection (1.3.0)
rmagick (2.13.1, 2.12.2)
rspec (2.8.0, 1.3.1)
rspec-core (2.8.0)
rspec-expectations (2.8.0)
rspec-mocks (2.8.0)
rspec-rails (2.8.1, 1.3.3)
ruby-debug (0.10.4)
ruby-debug-base (0.10.4)
ruby-rc4 (0.1.5)
rubygems-update (1.8.16, 1.8.15)
sanitize (2.0.3, 1.2.1)
savon (0.9.7, 0.7.9)
Selenium (1.1.14)
sendgrid_toolkit (1.1.0, 1.0.4)
sinatra (1.3.2, 1.2.6)
sitemap_generator (3.0.0, 2.1.0)
spork (0.9.0, 0.8.5)
sprockets (2.1.2)
SystemTimer (1.2.3)
systemu (2.4.2, 2.4.1)
term-ansicolor (1.0.7, 1.0.6)
test-unit (2.4.7, 1.2.3)
thinking-sphinx (2.0.11, 1.4.6)
thor (0.14.6)
tilt (1.3.3)
timecop (0.3.5)
toadhopper (2.0)
treetop (1.4.10)
ttfunk (1.0.3)
tzinfo (0.3.31)
unicorn (4.2.0, 3.0.1)
uuid (2.3.5, 2.3.3)
vagrant (0.9.7, 0.6.9)
vagrant-rake (0.1.0)
vegas (0.1.11, 0.1.8)
virtualbox (0.9.2, 0.7.9)
vpim (0.695)
wasabi (2.0.0)
webrat (0.7.3)
will_paginate (3.0.3, 2.3.16)
xml-simple (1.1.1)

Finally, here are the issues that occur when I run ruby script/console from a terminal:

* message appears:

"Sphinx cannot be found on your system. You may need to configure the following settings in your config/sphinx.yml file: ..."

one resource I found suggested that I needed to install Sphinx but even after doing an install of it, I still get this message

*I receive multiple instances of this message:

"NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01. Gem.source_index called from /Library/Ruby/Gems/1.8/gems/vagrant-0.6.9/lib/vagrant/plugin.rb:33"

one resource suggested I do gem update bundler or gem pristine --all --no-extensions but neither one worked and I still get these messages

*The final and perhaps worst error I receive:

/Library/Ruby/Gems/1.8/gems/mysql2-0.2.17/lib/mysql2/client.rb:44:in `connect':Mysql2::Error: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

One thing I noticed in most Ruby install recipes for OS X Lion (like this one: http://bit.ly/zs0VoP), when it comes to MySQL, they assume you need to install it as explained here:


5. Install Mysql

# brew install mysql

one-line command:

# mysql_install_db --verbose --user=`whoami` --basedir="$(brew --prefix mysql)" --datadir=/usr/local/var/mysql --tmpdir=/tmp

Thing is, I skipped this part of the install because I had already installed MySQL server before for use with another application.  I wonder if this is where my problems begin but I can't be sure.

So I would love to have some guidance on how to clean this up ... or if it makes more sense to start from scratch that's fine too but I'm not sure how to got about that since I have so many things installed already.

Max
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 20 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 20 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros