We help IT Professionals succeed at work.

problem with postfix configuration

504 Views
Last Modified: 2012-02-14
I'm trying to configure postfix for tls and having an issue.
I've been following this article:

http://www.howtoforge.com/howto_postfix_smtp_auth_tls_howto

I pasted the postfix -e lines and changed the domain to ours.  However, postfix won't start; saslauthd starts fine.

# postconf -n
postconf: fatal: /etc/postfix/main.cf, line 672: missing '=' after attribute name: "postconf -e mydomain = ourdomain.com"

This is line 672:
postconf -e 'mydomain = ourdomain.com'

I've been looking around for an answer for this and can't figure out why it's complaining about a missing =

running CentOS 5.7 x64
Comment
Watch Question

David BeveridgeLinux Systems Admin
CERTIFIED EXPERT

Commented:
try
postconf -e mydomain=ourdomain.com

no spaces around =
no quotes around parameter=value
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Post the config with the domain or privileged info I.e. public IPs.
There is no reason postconf should be in main.cf
Top Expert 2011
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Seth SimmonsLead Systems Administrator
CERTIFIED EXPERT

Author

Commented:
yup...totally misunderstood that section
ran the commands manually instead of in the file and works now
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.