ORA-28500: connection from ORACLE to a non-Oracle system returned this message

Experts -

I'm getting the error when I tried to connect from oracle to mysql via DBLINK.

I guess this is something to do with the User/privileges.

Need some help.

ERROR at line 1:
ORA-28500: connection from ORACLE to a non-Oracle system returned this message:
[Generic Connectivity Using ODBC]DRV_InitTdp: errors.h (2112): ;
[unixODBC][TCX][MyODBC]Access denied for user 'oracle'@'localhost' (using
password: YES) (SQL State: S1000; SQL Code: 1045)
ORA-02063: preceding 2 lines from MYSQL

tnsping mysql is ok

here is the dblink creation staement..

create database link mysql connect to "username" identified by "passwd"
using '(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = tcp)(HOST = testhost)(PORT = 1523))) (CONNECT_DATA = (SID = mysql)) (HS=OK))' ;
LVL 18
sventhanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Wasim Akram ShaikCommented:
Well the error states that Access denied for user 'oracle'@'localhost' (using

when did you get this error?

does the db link got created.. after creation of db link, did you tried select * from dual@dblink?

what does the output give?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Wasim Akram ShaikCommented:
Does the user exists? and does he have enough privileges on target database from where the data is being retrieved?
sventhanAuthor Commented:
Thanks experts. I created an MySQL account and I used that to solve this issue.

It seems to be an account/privilege issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.