Solved

Help with ASA 5510/PIX515 config (tunnel not working)

Posted on 2012-03-09
1
540 Views
Last Modified: 2012-06-27
I am trying to get the tunnel working between these two sites. I have ** all private info and left the ACLS dealing with the site I am having problems with. The first one is the PIX config, the next is the ASA.

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
hostname HoustonPIX
domain-name ***
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 110 permit ip 192.168.40.0 255.255.255.128 192.168.47.0 255.255.255.0
access-list 100 permit icmp any any
access-list 101 permit icmp any any
access-list acl_outbound permit tcp host 192.168.40.3 any eq smtp
access-list acl_outbound deny tcp any any eq smtp
access-list acl_outbound permit ip any any
access-list 147 permit ip 192.168.40.0 255.255.255.128 192.168.47.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside ***
ip address inside ***
ip address intf2 ***
ip audit info action alarm
ip audit attack action alarm
ip local pool PPTP 192.168.40.120-192.168.40.125
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 110
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
nat (intf2) 0 access-list 111
nat (intf2) 1 0.0.0.0 0.0.0.0 0 0
access-group 100 in interface outside
access-group acl_outbound in interface inside
route outside 0.0.0.0 0.0.0.0 ****** 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.40.0 255.255.255.128 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 1200
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto map Dallas 47 match address 147
crypto map Dallas 47 set peer ASA IP ADDRESS
crypto map Dallas 47 set transform-set myset
crypto map Dallas interface outside
isakmp enable outside
isakmp key ******** address ASA IP ADDRESS netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 86400
isakmp policy 44 authentication pre-share
isakmp policy 44 encryption des
isakmp policy 44 hash md5
isakmp policy 44 group 2
isakmp policy 44 lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 20
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
management-access intf2
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
terminal width 80
Cryptochecksum:8b541eac00b76cd92335fd752f0c29a6
: end




_____________________________________________________________________________________

ASA Version 7.2(4)
!
hostname ASA
domain-name *******
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.47.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address PUBLIC IP 255.255.255.240
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name spirerealty.com
access-list inside_nat0_outbound extended permit ip 192.168.47.0 255.255.255.0 192.168.40.0 255.255.255.128
access-list inside_NAT_outbound extended permit ip 192.168.47.0 255.255.255.0 any
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit icmp any any
access-list 130 extended permit ip 192.168.47.0 255.255.255.128 192.168.40.128 255.255.255.128
access-list 147 extended permit ip 192.168.47.0 255.255.255.0 192.168.40.0 255.255.255.128
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool 1177 192.168.47.20-192.168.47.49 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 access-list inside_NAT_outbound
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 ******** 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 192.168.47.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set MYSET esp-des esp-md5-hmac
crypto map TUNNEL_MAP 47 match address 147
crypto map TUNNEL_MAP 47 set peer PIX PUBLIC IP
crypto map TUNNEL_MAP 47 set transform-set MYSET
crypto map TUNNEL_MAP interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 1
 authentication pre-share
 encryption des
 hash md5
 group 1
 lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd dns *******
dhcpd domain ******
!
dhcpd address 192.168.47.50-192.168.47.80 inside
dhcpd enable inside
!
tunnel-group PIX PUBLIC IP type ipsec-l2l
tunnel-group PIX PUBLIC IP ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
0
Comment
Question by:j_crow1
1 Comment
 

Accepted Solution

by:
j_crow1 earned 0 total points
ID: 37715487
Seems the config was right, I just had to reboot the ASA and everything started working.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Some of you may have heard that SonicWALL has finally released an app for iOS devices giving us long awaited connectivity for our iPhone's, iPod's, and iPad's. This guide is just a quick rundown on how to get up and running quickly using the app. …
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now