Solved

Domian Controller Win Server 2008 r2

Posted on 2012-03-09
5
348 Views
Last Modified: 2012-08-13
I have set up a Domain Controller in a Windows 2008 r2 environment. I used the defaults and setup the DNS.  So far I have the server acting as the DHCP and the "Client" computers are connecting through the server (I think).  I have a router in the mix and the server is connected to it.    Here are some numbers:

Router
192.168.2.1
DHCP is disabled

Server:
Lan 1

IP Address 192.168.2.2
Subnet 255.255.255.0
Default Gateway 192.168.2.1

DNS 192.168.2.2
ALT  192.168.2.1

LAN 2
IP Address 192.168.2.3
Subnet 255.255.255.0
Default Gateway 192.168.2.1

DNS 192.168.2.2
ALT  192.168.2.1

The DHCP range is 192.168.2.101 to 200

I can look at the leases in the Server and all of my computers and printers are listed.

I have added the computers in question to the Active Directory. (As well as the user)


Anybody have any ideas
0
Comment
Question by:Pat Clancy
5 Comments
 
LVL 39

Expert Comment

by:Adam Brown
ID: 37702841
Well, it's generally recommended that a Domain Controller only have 1 NIC...but I'm not sure if I'm reading your post correctly. Is there an issue you're running into with this setup?
0
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 250 total points
ID: 37702846
You need to disable all network cards except for one if you are running this server as a DC. DCs shouldn't be multihomed servers.

Second you need to remove ALT  192.168.2.1 this is not a internal DNS server for your domain. When you are on a domain your DCs, member servers, and clients should only point to internal DNS servers which are usually DCs only.

After doing the above go to command prompt ipconfig /flushdns, ipconfig /registerdns, and dcdiag /fix
0
 
LVL 10

Expert Comment

by:Bawer
ID: 37702943
just a question, why you have two nics in the domain controller, although a DC can have two NICs if the ranges are different however i see both the LAN IPs are from similar subnet,
0
 

Author Comment

by:Pat Clancy
ID: 37703062
I did not know that I could only have one NIC I have disabled the second one. I am working on solution 2 at the moment.

I'll let you all know what happens and thank you for you quick responses.

Thanks
0
 

Author Closing Comment

by:Pat Clancy
ID: 37703557
I also went into the properties of the computer that I wanted to join the domain and added the Address to the DNS port. then was able to join the domain straight way.  Thank you for your help.
0

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

815 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now