Solved

Port blocked on router end

Posted on 2012-03-10
3
447 Views
Last Modified: 2012-03-10
Hi guys,

Port 80 is supposedly block but not by my ISP. I confirmed with ISP that it has been open. I dont have a firewall and was wondering if my cisco 2650 router can block port 80.

See config below and let me know if anything needs to be fixed.



2650Router#sho run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2650Router
!
enable
!
username
!
!
!
!
ip subnet-zero
ip domain-name .com
ip name-server 4.2.2.2
!
!
!
!
interface FastEthernet0/0
 description INTERNAL LAN PORT
 mac-address xxxx
 ip address 10.10.10.60 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
!
interface Ethernet1/0
 description INTERNET LAN PORT
 ip address xxxx 255.255.255.248
 ip nat outside
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
ip nat inside source list NAT-ADDRESSES interface Ethernet1/0 overload
ip nat inside source static tcp 10.10.10.90 25 interface Ethernet1/0 25
ip classless
ip route 0.0.0.0 0.0.0.0 xxxx
no ip http server
!
!
ip access-list standard NAT-ADDRESSES
 permit 10.10.0.0 0.0.255.255
 permit 10.10.10.0 0.0.0.255
 permit 10.10.20.0 0.0.0.255
!
line con 0
 exec-timeout 30 0
 password
 logging synchronous
 login local
 transport input none
line aux 0
line vty 0 4
 exec-timeout 30 0
 password
 logging synchronous
 login local
!
no scheduler allocate
end


Do I have to do a NAT? If so, what is the cmd.

Thanks
0
Comment
Question by:vmagan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 34

Accepted Solution

by:
Istvan Kalmar earned 500 total points
ID: 37705488
Hi,

you need:

ip nat inside source static tcp 10.10.10.90 80 interface Ethernet1/0 80
0
 
LVL 26

Expert Comment

by:akahan
ID: 37705879
Your router blocks unsolicited packets on EVERY port, unless you specifically open them.
0
 
LVL 6

Author Closing Comment

by:vmagan
ID: 37706056
That did it. Thanks
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ASA Troubleshooting: Easy way to determine an interface's next hop 18 111
configure ASA Vlan Interface 14 101
Extended ping 6 56
BGP max path 2 1 21
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question