I'm starting a development project and would like to know: How to name my variables, data fields, modules, etc.
What are the most sensible ways to name objects, etc.
Surely someone has a clear answer.
C++Java.NET Programming
Last Comment
evilrix
8/22/2022 - Mon
for_yan
The best way is to give them natural names - if your object represnts a Student call class Student, if it represents a Professor call class Professor
If the fields inside represent name, age, cal them this way - it is all very straighforwward
It is very much recommended also to follow convention accepted for the language,
say in java you name classes starting with capital letters, fields and methods start with lower case; several words represent with starting each word (other than the forst for a field) capitalized, (I guees it si called camel concvention or something)
say
bookTitle
bookPrice
What language? Coding styles that make sense in one language don't necessarily make sense in another.
IMHO people spend far too much time worrying about style and not enough time worrying about code quality (in terms of it being robust, not how pretty it is). Once it's compiled it all looks the same anyway. Code should be readable and maintainable; that really is all that matters. Put your effort into defining coding quality standards (for example, ensuring all functions enforce one of the three exception safety guarantees or that you always use smart pointers to manage memory allocation).
As a general case; however, it helps (and makes sense) that classes should be nouns, functions should be verbs and variable names adjectives as they generally indicate an attribute or a noun. Don't be tempted to indicate the variables type in the name. You'll regret this if you refactor the code and change the type!
Example (borrowing from for_yan's example of Student):
class Student // noun{ void do_homework(); // verb int age; // noun bool is_sleepy; // adjective};
For example, if you have a bool indicating whether something is ready call it is_ready rather than ready_flag. Aim for self documenting code. Don't get too bogged down with style; however. It really doesn't matter whether you call your functions DoSomething or doSomething or do_something. What does matter is that you're consistent.
I've read so many coding standard the try to enforce the (half based) preferred style of the author. For example, they'll often call for using "Hungarian Notation" as a naming convention or insist that a certain level of indentation is used (python zelots go mad if you use anything other than 4 spaces for each level!). It's all nonsense. If you can code you can read code regardless of the style used. It becomes a lot harder if that style is not consistent.
So, my advice is don't waste too much energy on this. Have a few loose set of guidelines that every one can work to and leave the detail up to the engineers. You should be peer reviewing code. If an engineer goes completely bonkers and start using (for example) l33t for variable names you can just reject it. I promise they won't do that too many times :)
If the fields inside represent name, age, cal them this way - it is all very straighforwward
It is very much recommended also to follow convention accepted for the language,
say in java you name classes starting with capital letters, fields and methods start with lower case; several words represent with starting each word (other than the forst for a field) capitalized, (I guees it si called camel concvention or something)
say
bookTitle
bookPrice