Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 387
  • Last Modified:

Added Table to .EDMX but can't get Context to Reflect Changes

Hi,
I had an existing .edmx file/diagram.  I added a new table to diagram and ran the 'Update Model from Database' option by right clicking on diagram.  When I reference my Domain Context variable the method m_DomainContext.GetYYYQuery() (where YYY is the name of my newly added table) does not exist.  How can I get the context to update? I am working with Visual Studio 2010.
Thanks in advance for the help!!!
Terry
0
wahlster
Asked:
wahlster
2 Solutions
 
Miguel OzSoftware EngineerCommented:
0
 
apeterCommented:
After adding hope you rebuild the project which contains the edmx file. This issue is there in .net 3.5 but happens very less in .net 4.0.  Worst case recreate the edmx file.
0
 
wahlsterAuthor Commented:
I did add the table with the wizard.  I did read the section as proposed by mas_oz2003 but no luck.  I then added a little hope per apeter and recreated teh edmx file.  This seemed to be part of the solution but in my project I also have a DomainService class that also had to be recreated.  This domain class appears to work with tables in the edmx class.  Once I recreated both of these things work but this seems a bit extreem.  I am getting up to speed with RIA so I may be missing the obvious.  Any additional input/insight would be greatly appreciated.
Thanks,
Terry
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now