Remote Desktop cannot connect remotely to windows server 2008 r2

The remote server is setup with terminal services. I have tested the remote desktop connection to the server itself and it works. But cannot connect from a remote location / site. I have Teamviewer installed and I have no issues connecting from a remote location to the server location via teamviewer. The only other thought that I have is that a private role may be overriding the connection.
spcpyltAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

systechadminConsultantCommented:
Please make sure  the RDP port is enable from the firewall....
0
Martin81Commented:
If you can RDP to the server from another server or client at the same site then it probably isn't the RDP setup that's the problem it's more likely to be either that you can't route to that site from where you are, or a firewall between you and that site is blocking the connection.
0
lojk.Net and Infrastructure ConsultantCommented:
If the server is fully exposed to the internet with a full public IP it will just be a firewall (blocking) issue  - if the server only has an internal IP (10.x.x.x, 192.x.x.x) then you will need to forward the port on the router to that servers internal IP.

Team viewer does not require an incoming connection (port forwarding rule) as it makes an outgoing connection from both sides of the connection to a shared location that is on the internet.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jsrebnikCommented:
Assuming that your server is sitting behind a router/firewall, make sure that inbound traffic on port 3389 is being forwarded to the internal i.p. address of the server.
0
surendarpCommented:
Please make sure  the RDP port is enable from the firewall....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.