Solved

iCAL Email Notification Nightmare

Posted on 2012-03-11
5
963 Views
Last Modified: 2012-03-27
I have been struggling big time with the iCal EXTERNAL notifications to work.

We have our ISP X that provides us with email that has domain mybusiness.com
I first attempted to set up ical email notifications but I could not get it to work with an external ISP Email host solution.
Then, I proceeded to use the OSX Server as the Mail server and create an account linked to my iCal Admin so the email would be iCalAdmin@mycompany.com
Sending an email works Great but the problem happens when external users attempt to reply and here is where I would like some guidance:

We all know that external replies to ical invites have the format of <user+32432432423432@mycompany.com> When external users reply to my ical notification, they get an undeliverable email...why? because mycompany.com mail server is handled by my ISPs!! hope its not too confusing...the easy answer would be to change the domain of my ical server but I want to know if someone ever got this working right with an ISP email hosted environment.

Hope it is clear; if not let me know! Thank you
0
Comment
Question by:ArgieIT
  • 3
  • 2
5 Comments
 
LVL 10

Expert Comment

by:robertcerny
ID: 37708604
Change DNS MX settings to point to your mail server.
0
 

Author Comment

by:ArgieIT
ID: 37709511
True but by doing that, then all my users who use @mycompany.com will not be able to use the ISP provided email service and I will have to bring email "in-house"

There has to be a way for me to use my mail server ONLY for ical notifications and leave the rest as is
0
 
LVL 10

Expert Comment

by:robertcerny
ID: 37709847
No way. Sorry. Only idea - use a different domain for iCal only, but I wouldn't recommend it.
0
 

Author Comment

by:ArgieIT
ID: 37709919
With that said, the only way to make ical external invitations to work is to use in-house mail system?

I was able to use outside accounts such as hotmail,gmail,etc to work (with mail disabled in ical) but when users respond, the response is sent naturally back to that hotmail/gmail account hence the ical server can't translate the response and forward to appropiate user.

Any workarounds?
0
 
LVL 10

Accepted Solution

by:
robertcerny earned 500 total points
ID: 37709938
The issue is with the mail server settings, which you can't change because it's not under your control. To allow delivery to <user+32432432423432@mycompany.com> you need to set MTA to accept such a user otherwise it's tagged as a mail for not-existing user and delivery is canceled.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SMTP Service 9 52
Exchange 2013 logs for troubleshooting mailflow 3 49
Printer from iMac not available in Citrix session 7 42
Exchange 2010 - Default Receive Connector 2 33
Utilizing an array to gracefully append to a list of EmailAddresses
Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

825 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question