Troubleshooting iPhone 4s Calendar Sync Issue

Hi There!

We have a customer who replaced her older iPhone with this new 4S. The old phone was working perfectly for all content to sync from her exchange account in both directions.

This phone everything works except only 1 direction (server to phone) for Calendar.

What steps can I take other than removing the account and re-adding which I have already tried and it didn't work.

Basically nothing inputted from from the calendar on the phone is syncing back to the server.

Exchange 2007 fully patched.

Cheers
networknAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ezskolCommented:
Have you tried updating to IOS 5.1 and see if that works?

Is there more than 1 calendar running on her iPhone?  It might be something issues having more than one calendar or even ensure the following is set correctly:

Check Settings > Mail, Contracts, Calendars > Sync - All Events?
0
Alan HardistyCo-OwnerCommented:
The way to test this is to use OWA.

If after adding an appointment on the iPhone, it doesn't appear in OWA, then delete the Exchange account from the iPhone, reboot the iPhone and add the account again, then test again.

If it makes it to OWA (from the iPhone), then check Outlook and if it doesn't make it there, delete and recreate the Outlook .ost file )with Outlook closed), then open Outlook up again and test again.
0
ishcabittleCommented:
Also check to see if the user is entering calendar events into the Exchange calendar and not a superfluous iCloud calendar.  It's a simple error, but it is common.
0
PeerbolteCommented:
In addition:

To set the iPhone to save the items in the Exchange calendar by default, do the following:
1. Open settings --> e-mail, contacts, calendars
2. Scroll down to the Calendars part and tap Default calendar
3. Select the Exchange calendar.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
networknAuthor Commented:
This was the problem thank you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iOS

From novice to tech pro — start learning today.