Can not get IP Address

Hi All,

I have an XP Machine that can not get an IP address :(

It is a coworkers and they got a virus on Friday, rebooted and now can not connect to the internet.

They are using Microsoft Security Essentials.

I think it has to do with Network Location Awareness not running.  When I try to start it I get: "Could not start the Network Location Awareness (NLA) service on Local Computer.  Error 1075: The dependency services does not exist or has been marked for deletion."

I have ran:
netsh int ip reset reset.log
netsh winsock reset catalog

This did not help.

I also ran sfc /scannow and it returns with error.. (I think it just returns without anything, but is running Windows File Protection with my windows disk)

Please HELP!
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

try to boot in safe mode with lan
see if an internet will show
if not, try to use this tools for registry clean-up,
ccleaner in windows safe mode
disable all the autorun using ccleaner also
use also, autoruns and see services that needs to be enabled or auto
net stop winmgmt
Rebuild the repository, rename the folder to something else as a backup.
ren %windir%\System32\Wbem\Repository Repository_old
Start WMI service:
net start winmgmt
Repair the repository:
Windows XP:
rundll32 wbemupgd, UpgradeRepository

Register the new WMI components:
cd /d %windir%\system32\wbem

for %i in (*.dll) do RegSvr32 -s %i
for %i in (*.exe) do %i /RegServer

Reboot the computer for the changes to take effect.
That should fix your WMI repository.

If all above steps don't work for you, try comprehensive rebuild below:
rundll32.exe setupapi,InstallHinfSection WBEM 132 %windir%\inf\wbemoc.inf

Above command will ask for your Windows XP installation disc so be prepared.

Launch command line and execute the following command:
netsh winsock reset
ilcapocamorraAuthor Commented:
Thanks all I have tried this without success...

Note the issue is that I am unable to get an IP address... I see "acquiring network address" but it never acquires.

This is directly into the router, other machines work fine :(
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

Delete the network adapter from device manager.
Re-install hardware device with new drivers (force it).

Re-run network wizard...yes the wizard.  Sounds crazy, but this is one wizard that worked well in XP.
ilcapocamorraAuthor Commented:
Hi Iron Man,

Tried this too, no work :(
Run a protocol analyzer and check for the DHCP packets like DHCP Discover, DHCP Offer . This would help you to identify where the problem is. Check if the DHCP Discover packets are reaching the DHCP server.
☠ MASQ ☠Commented:
This may help you spot what part of the TCP/IP stack has been damaged by the virus infection.

And as an outside chance, have you tried restarting/resetting the DHCP server?
ibu1Senior System AdministratorCommented:
Download and run WinSockfix ip fix utility from here,
Others possible fixes:

Check your hosts file to make sure of improper entries.

Run system file checker:

Download HiJack this (from another machine of course), run a scan and post log here
ilcapocamorraAuthor Commented:
sfc, hijack this and host files are all good

I have just checked and I don't have DHCP Client in services, how do I reinstall this??

I tried:

But on step 6, there is no DHCP Service listed :(
Check your Event logs to see if it failing to start to to a dependency issue.

Also, list what services and protocols are install under the properties for your network adapter.
ilcapocamorraAuthor Commented:
event viewer coming up....

Network Adapter
Client for Microsoft Networks
File and Printer Sharing for MS Networks
Qos Packet Scheduler
Internet Protocol (TCP/IP)
ilcapocamorraAuthor Commented:
event viewer, renamed as txt
ilcapocamorraAuthor Commented:
bought a new computer...
Back-up / transfer files to new computer.  Re-install OS on old PC.   Sorry we couldn't get to the answer soon enough.
I hope you have tried MASQUERAID comment


Try to find <srvsvc.dll> in your windows system32 folder, if not there, copy from another same xp computer

and also this: <wkssvc.dll>

then restart after putting the files to your computer,
after restart,
also visit your services, if Server service is running and Workstation Service is running,
check also DNS and DHCP Client is started

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ilcapocamorraAuthor Commented:
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.