new subdomain redirect in iis 6.0

About me: Our web admin just quit his job and my boss ask me (software developer who only know the basic concept of web server) to administrative 2 web servers. Both server has same settings and webpages because of server load balance (?).

OS : Windows 2003 IIS : 6.0

My problem: Before last week, we use this url "index.sally.home.gettherabbit.com" for our homepage. When users type "index.sally.home.gettherabbit.com" in their browsers, it will takes the users to "https://index.sally.home.gettherabbit.com" and dont give cert error. My boss ask our network guy to create a new domain "sally.gettherabbit.com". The problem : When some users type "sally.gettherabbit.com" , the browser bring them to "https://sally.gettherabbit.com" and prompt user login before continuing to the homepage (https://index.sally.home.gettherabbit.com). When the same users type "https://index.sally.home.gettherabbit.com", it give cert error and a warning to continue to the page. After the users proceed, the browsers still take them to "https://index.sally.home.gettherabbit.com" with cert error in the url bar.

While some users dont have any problem when type "sally.gettherabbit.com", it redirect to the right url "https://index.sally.home.gettherabbit.com".

Is this my fault? iis server fault? or the network guy who create the new domain?

In Command Prompt: Ping sally.gettherabbit.com (the message shows it points to 10.10.10.100) - i think this load balance server.

Web Server 1 10.10.10.33 Web Server 2 10.10.10.22

Thanks
klboyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jon BrelieSystem ArchitectCommented:
It depends on what you want here.  Do you want sally.gettherabbit.com to be a seperate page that does not require SSL?  Or do you want it to support SSL?  Do you want it to redirect to index.sally.gettherabbit.com?  Or should it be it's own page?

If you just want it to redirect users to https://indexsally.gettherabbit.com - Go to the Home Directory tab of the site properties and select "re-direct to a URL," and enter that url there.
0
klboyAuthor Commented:
extra info :
my boss want "sally.gettherabbit.com" redirected to  "https://index.sally.gettherabbit.com/homepage" .

When i type ping "sally.gettherabbit.com " in command prompt, the reply is "Pinging index.sally.gettherabbit.com [10.10.10.100]" . Is this mean "sally.gettherabbit.com " pointing to the right url [10.10.10.100]?

In my theory, browsers should not ask user login if the user type  "sally.gettherabbit.com " 

The route : "sally.gettherabbit.com" ------> "http://index.sally.gettherabbit.com" --> "https://index.sally.gettherabbit.com/homepage

default.aspx file in web root folder redirect to "https://index.sally.gettherabbit.com"


my problem is Why the browser requires user login for "sally.gettherabbit.com " , but no problem for  "http://index.sally.gettherabbit.com"
0
Jon BrelieSystem ArchitectCommented:
Have you tried the URL redirect I mentioned?
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

klboyAuthor Commented:
yes, i change the home directory's URL redirect to "https://index.sally.gettherabbit.com/homepage" . As result:


sally.gettherabbit.com  ---> still requires user login
https://index.sally.gettherabbit.com/homepage  ---> website can not be acccess
0
Jon BrelieSystem ArchitectCommented:
On the Directory Security tab, what do you have under Authentication and Access control for http://sally.gettherabbit.com?

Make sure you have checked "enable anonymous access" and that the account is set to IUSR_machinename

Also make sure that that user has NTFS access to the webroot for that site.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
klboyAuthor Commented:
"On the Directory Security tab, what do you have under Authentication and Access control for http://sally.gettherabbit.com?"
Enable anonymous Access - checked
Authenticated Access - Integrated Windows Authentication


i just found out this is an intranet environment. the domain only work in intranet network.

i added http://sally.gettherabbit.com in IE trusted intranet sites list, now the browser (ie,chrome) dont require user login when type http://sally.gettherabbit.com (redirected to "https://index.sally.gettherabbit.com/homepage"). For firefox , i change the network:automatic-logon settings.

Now the problem is how i do this in IIS server? to change the browser setting in 200 local PC is not really effective.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.