• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2140
  • Last Modified:

Unable to set up port forwarding on Juniper SSG-5 with dynamic IP.

I am attempting to set up port forwarding with a Juniper SSG-5 on my connection that has a dynamic IP. I am aware you're supposed to configure a VIP, but when I create a VIP on the untrust interface (and select "same as the interface IP address"), it creates it, but when I go to edit it, the Juniper will not allow me (I click edit, but nothing happens). Therefore, I cannot add a service (custom or otherwise) to be forwarded to an internal IP. I can remove it the newly-created VIP, and re-create it, but I cannot edit it (needed to add services, point to an internal IP, etc). Again, when I click "edit", it just sits there, and no options for adding services or anything else appear. I've tried multiple browsers, and they all exhibit the same behavior.

My specific Juniper version is the SSG5v-92, and the firmware version is 6.3.0r9.0. Is there something I'm doing wrong? Why can I not edit this newly-created VIP to add a service and point to an Internal IP to allow for port forwarding?
0
VLib
Asked:
VLib
  • 2
  • 2
3 Solutions
 
cdfsCommented:
Have you followed the steps described in the following KB-article: http://kb.juniper.net/InfoCenter/index?page=content&id=KB4740
0
 
deimarkCommented:
First thing to ask here biud.

When you create the VIP, you shouldnt be able toe dit it, you cvan either add or delete.

However, once the VIP is created we can then add VIP services, this is the bit that we need to create incoming services.

And as above, follow that link to create VIP bud and it will be all good.
0
 
VLibAuthor Commented:
Thank you. I followed that guide, but when I got to adding the service, when I try to add port 80 (HTTP), it tells me "Not supported service: port 80 is for management of the box". It does the same with port 443 (HTTPS). I am trying to pass traffic through to an internal web server. Is this not possible? I don't have Web UI enabled for the Untrust interface, yet it still does this. How do I pass HTTP or HTTPS traffic through using VIP?
0
 
cdfsCommented:
Check the configuration of your interfaces. Besides activating management zone-wise, you can also configure it for every interface, so make sure, management isn't activated on the interfaces that are in your untrust-zone.
0
 
deimarkCommented:
Yup, as above, consider changing the management services for the web UI to some other port, ie instead of port 80 use 8080 and instead of port 443 for SSL use 4434 or similar.

The error you get is cos the management services are still bound default ports and you cant bind a VIP service to a management port sadly.

HTH
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now