Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Laptop can't see Server & won't join domain

Posted on 2012-03-12
16
Medium Priority
?
248 Views
Last Modified: 2012-03-23
Hi All

Although a techie, my speciality isn't in servers (painfully obvious) but I'm trying to help someone out & onto the right path.

I've done some work sorting out network shares etc. But there's one machine I can't get joined onto the domain.

It's running XP Pro SP3. I created a new user on the server (MS Server 2003) but when I try & join the laptop to the domain (via rightclick>MyComputer>Network ID) it refuses to join.

Have I done something daft? Can anyone walk me through the steps & see if I've overlooked something obvious?

Many Thanks.
0
Comment
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
  • +3
16 Comments
 

Expert Comment

by:it_related
ID: 37709866
First of all,

Are you logged in as a local admin on that laptop?
0
 
LVL 7

Expert Comment

by:raeldri
ID: 37709973
Are the DNS servers set correctly the machine will use DNS to locate the domain ?
0
 
LVL 1

Author Comment

by:sefton-computer-repairs
ID: 37709996
There's only one (local) user on that laptop and is set as an admin.

No explicit DNS servers set, IP & DNS both set to auto. (Standard SoHo Netgear ADSL/wifiRouter acts as Gateway on 192.168.0.1)
0
How Blockchain Is Impacting Every Industry

Blockchain expert Alex Tapscott talks to Acronis VP Frank Jablonski about this revolutionary technology and how it's making inroads into other industries and facets of everyday life.

 
LVL 17

Expert Comment

by:Sikhumbuzo Ntsada
ID: 37710006
Check your IP settings and make sure it is using a correct DNS server.
0
 
LVL 7

Accepted Solution

by:
raeldri earned 1000 total points
ID: 37710011
for domain join to function the routers DNS server isnt going to work. it needs to be set to the correct DNS server (very likely a DC)
0
 
LVL 1

Expert Comment

by:Turkey1974
ID: 37710053
What is the error message you receive when trying to join the domain?
0
 
LVL 1

Author Comment

by:sefton-computer-repairs
ID: 37710114
(The laptop does still connect to the internet incidentally).

The Server is just hung off the router so should I use its IP as the DNS? (Educate me: How does that then work for Internet DNS?)

Error Msg: Can't quite remember as it was the end of a long day but I was getting a simple message along the lines of "Unable to join domain" (useful!)

I also got a message along the lines of "multiple users not allowed to join domain". There was no other user on the laptop, no other logged on users using the same username on the server. The laptop was shown in the computer list on the managament screen, tried deleting that & no joy. (Tried adding it back, still no joy).
0
 

Assisted Solution

by:it_related
it_related earned 500 total points
ID: 37710121
You don't need to set up anything specific for DNS settings as they should be provided as part of your DHCP ip address. The issue here is if the machine can't find itself to be in the same domain, (ie family subnet) it won't be able to access the DC when you request to join. If you can connect to the internet, then you should be able to see your domain. Now, are you using a domain admin account to join, correct?

if you can't see the internet, then use the following commands to reset your IP and Windsock interfaces and clear the dns cache:

c:\>ipconfig /flushdns
c:\>netsh int ip reset > resetlog.txt
c:\>netsh winsock reset

after this you will have to restart your pc. Then try again
0
 
LVL 7

Expert Comment

by:raeldri
ID: 37710185
In order for the computer to be able to resolve the domain name and find the servers the DNS server it uses must know of the AD domain a consumer router is just forwarding requests to an internet server, you might be able to configure the DHCP options on the router to use the servers IP for DNS.

DNS on a windows server will forward requests it cant resolve to the root dns servers, this works but should be avoided. you can configure forwarding on the server. if you can provide more detail about the server OS i can provide instructions
0
 
LVL 1

Author Comment

by:sefton-computer-repairs
ID: 37710297
I can see the Internet. Other machines are working fine so I'm loathe to alter anything on the Server, it's just this one laptop.

I'm wondering now if I've not used a domain admin account to join as this machine is for a new user whereas others were generally using existing users. (Although I think at least one was a new user ID and that worked fine).

Is it as simple as ensuring that the user ID is a member of 'domain admins'? (Or just using the Adminsitrator ID to do the first join)?
0
 
LVL 7

Assisted Solution

by:raeldri
raeldri earned 1000 total points
ID: 37710398
any domain admin user ID will allow joining but any user account can join a machine up to 10 times to a domain by default.

your really going to need to get the error in detail to track down the issue
0
 
LVL 1

Assisted Solution

by:Turkey1974
Turkey1974 earned 500 total points
ID: 37710516
try filling the username field as:

DOMAIN\USERNAME

ensure that it is a backward slash separating the two without spaces

e.g. mountain.peak.local\administrator
0
 

Expert Comment

by:it_related
ID: 37710571
I believe that by now you should have enough information to add that computer to the domain. Are you still getting an error? If so what is it?
All of these great minds would be able to help once you provide more detail on the matter.
0
 
LVL 1

Author Comment

by:sefton-computer-repairs
ID: 37710674
:) I'm back in there tomorrow so will let you know what happens!

I've got a lot of good pointers from the thread, thank you all & I hope to be back with some good news in 24hrs!
0
 
LVL 13

Expert Comment

by:rhinoceros
ID: 37713476
The basic one - Laptop's "TimeZone" is correct with server before join domain?
0
 
LVL 1

Author Closing Comment

by:sefton-computer-repairs
ID: 37758816
Thanks everyone. I got it working but I'm not exactly sure where the root of the problem lay in the end. I suspect it was tied up with the DNS settings on the laptop as changed those to both the router IP & Google's public DNS IP and it managed to see the server/DC again.

Changed 'em back to auto & working fine so suspect that helped flush things through & gave it a range of DNS possibilities.

Put several brand new machines on at the same time & they worked fine, first time with everything set to auto so I'm not going completely mad :)

That laptop is mighty cranky anyway so I suspect its days are numbered. But I've learnt a lot from the thread so thank you all - I shall now retreat to my usual world of SEO & Social Media :)

Thanks again
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

by Batuhan Cetin In this article I will be guiding through the process of removing a failed DC metadata from Active Directory (hereafter, AD) using the ntdsutil tool in a Windows Server 2003 environment. These steps are not necessary in a Win…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question