VMWare ESX 5: configure multiple ISCSI (Hanccoka?)

Posted on 2012-03-12
Medium Priority
Last Modified: 2012-03-14
To Hanccoka: thanks for all your input on my questions! Would be great if you could give input on this question too.

Since the patch on my NAS (by Synology) solved a lot of problems, I tried again configuring my ISCSI's according your link:

Now I see I have 2 things different then in your manual:
-when I want to bind the vmkernel iscsi network I also see the management vswitch (not in your screenshot)
-I added the dynamic links manually (added both ip addresses of my NAS x.x.x.x)

Furthermore I see events in my ESX (only one configured, in standby mode now):

2010-10-14T19:46:04.900Z cpu1:3755)ScsiPath: 4541: Plugin 'NMP' claimed path 'vmhba37:C2:T0:L0'
2010-10-14T19:46:04.936Z cpu1:3755)<3>ata5.01: bad CDB len=16, scsi_op=0x9e, max=12
2010-10-14T19:46:04.941Z cpu0:2653)NMP: nmp_ThrottleLogForDevice:2318: Cmd 0x1a (0x4124007b0040) to dev "mpx.vmhba1:C0:T1:
2010-10-14T19:46:04.941Z cpu0:2653)ScsiDeviceIO: 2316: Cmd(0x4124007b0040) 0x1a, CmdSN 0x110f to dev "mpx.vmhba1:C0:T1:L0"
2010-10-14T19:46:04.999Z cpu1:3755)<3>ata5.01: bad CDB len=16, scsi_op=0x9e, max=12
2010-10-14T19:46:05.154Z cpu0:3755)Vol3: 647: Couldn't read volume header from control: Invalid handle
2010-10-14T19:46:05.154Z cpu0:3755)FSS: 4333: No FS driver claimed device 'control': Not supported
2010-10-14T19:46:05.154Z cpu0:3755)<3>ata5.01: bad CDB len=16, scsi_op=0x9e, max=12
2010-10-14T19:46:05.157Z cpu1:3755)<3>ata5.01: bad CDB len=16, scsi_op=0x9e, max=12
2010-10-14T19:46:05.159Z cpu1:3755)<3>ata5.01: bad CDB len=16, scsi_op=0x9e, max=12
2010-10-14T19:46:05.161Z cpu1:3755)<3>ata5.01: bad CDB len=16, scsi_op=0x9e, max=12
2010-10-14T19:46:05.165Z cpu1:3755)FSS: 4333: No FS driver claimed device 'mpx.vmhba1:C0:T1:L0': Not supported
2010-10-14T19:46:05.412Z cpu1:3755)VC: 1449: Device rescan time 93 msec (total number of devices 9)
2010-10-14T19:46:05.412Z cpu1:3755)VC: 1452: Filesystem probe time 392 msec (devices probed 8 of 9)
2010-10-14T19:51:23.471Z cpu0:20426)WARNING: UserObj: 675: Failed to crossdup fd 8, /dev/ptyp0 type CHAR: Busy
2010-10-14T19:51:23.471Z cpu0:20426)WARNING: UserObj: 675: Failed to crossdup fd 10, /dev/ptyp0 type CHAR: Busy
2010-10-14T19:51:23.472Z cpu1:20455)WARNING: UserLinux: 1340: unsupported: (void)

Now, pracital questions:
-please advise if you see any incosistencies in my config
-please advise if you would configure trunks (I will make vlans -new ticket I will create for migrating to vlans -bought a Sonicwall firewall-)

Note: for now (15 minutes) everything is working fine, however no vm's are running on it.

Question by:janhoedt
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
LVL 122

Accepted Solution

Andrew Hancock (VMware vExpert / EE MVE^2) earned 2000 total points
ID: 37710357
Yes, in my article, I've setup a new vSwitch.

Check the number of paths to the NAS, there should be two paths per iSCSI LUN.

also you can login to ESXi via SSH or Console, and use ESX top, and check the traffic on the NICs, this is iSCSI traffic.

logs look normal and refer to local SATA devices (maybe) or it's a CDROM - mpx.vmhba1:C0:T1:L0

Author Comment

ID: 37716782
Switches setup according your article on all my ESX hosts. No issues at all for now (1 day).
LVL 122
ID: 37716790
very good.

Author Comment

ID: 37719708
2nd day without any issues, I'l have to conclude my nas had troubles and the update solved them all (NFS as well as this issue).

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

HOW TO: Upload an ISO image to a VMware datastore for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5) using the vSphere Host Client, and checking its MD5 checksum signature is correct.  It's a good idea to compare checksums, because many installat…
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
Teach the user how to rename, unmount, delete and upgrade VMFS datastores. Open vSphere Web Client: Rename VMFS and NFS datastores: Upgrade VMFS-3 volume to VMFS-5: Unmount VMFS datastore: Delete a VMFS datastore:
Teach the user how to use vSphere Update Manager to update the VMware Tools and virtual machine hardware version Open vSphere Client: Review manual processes for updating VMware Tools and virtual hardware versions: Create a new baseline group in vSp…
Suggested Courses

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question