Windows 2008R2

Hi

I have two serves, server1 running SBS 2008 Stnd, server2 running Windows server 2008R2, they are at seperate sights.

I want W2k8r2 to join the domain but am having DNS resolution issues.

I am using Hamachi (logmein) as the software to create the VPN tunnel. I can browse all data files on server1 from server2.

I need server2 on the domain for users, permissions etc.

thanks

C
DansamCSAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kdubendorfCommented:
I haven't had much luck joining domains across a VPN.   Is there anyway to move the R2 server to the site of the SBS temporarily?  Join it to the domain and then relocate it back to it's home.  

Also, I would recommend making sure that you setup the R2 server so that it can provide login services locally.
0
Neal58Commented:
check your DNS settings are pointing at the remote site. Also if joining a domain add .local to the domain.
0
Rob WilliamsCommented:
Joining the domain over a VPN is no problem, but using Hamachi adds problems because of their addressing.  I would recommend for stability purposes using a proper VPN hardware solution. They start at about $200 each such as the Cisco/Linksys RV042 which works well for this purpose.

Firstly to join the domain you must have the remote server point ONLY to the LAN IP of the SBS. It will not work if an ISP or the local router is used, even as an alternate. Then you need to add the DNS suffix to the DNS tab of the advanced TCP/IP properties.
http://lantechca.files.wordpress.com/2011/05/vpn-dns2.png

If you can now ping the server by its NetBIOS name (simple name) you should be able to join the domain.  The http://connect  will not work for adding the server so you need to do so under computer properties.

If you cannot ping by name you will need to add static routes at both ends of the tunnel such as:
Route –p add  <SBS subnet>  mask 255.255.255.0  <Local Hamachi IP>
For example  
Route –p 192.168.100.0 mask 255.255.255.0  5.123.123.123
The SBS site will need to have the opposite.

If the client machines are to access SBS resources, every PC will need the route added.  This is not the case with a site-to-site hardware solution.

Keep in mind both sites must use different local subnets like 192.168.100.x and 192.168.200.x

Once joined you need to moce the Server to the appropriate OU in active directory, and set up the site and subnets in Active Directory Sites and Services.  You can then run DCpromo on the remote server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

DansamCSAuthor Commented:
Thanks for info above, I can ping by name and receive replies from the hamachi IP address but still having issues with DNS when trying to join domain

C
0
Rob WilliamsCommented:
Is there more than one NIC enabled on the server trying to connect to the domain? If so disable all but one until joined.

I am not certain what complications the Hamachi VPN adds but normally you would have a site to site VPN with two routers such that you have

192.168.100.x <=> VPN <=> 192.168.200.x
With Hamachi you have
192.168.100.x <=>5.x.x.x<=> VPN <=> 5.x.x.x<=>192.168.200.x

It may be athat Hamachi is somehow interfering. You can ping so it doesn't seem to be a name resolution or routing issue.  It may be that the server has two NIC's a physical and a Hamachi Virtual.  Try connecting the Hamachi VPN, then under network adapters | IPv4 properties | Advanced | DNS | add the SBS as the DNS server as well as adding the domain suffix.
0
DansamCSAuthor Commented:
Hi Guys

Update on this issue, the server is a cloud based server running W2K8r2, the image was corrupt, an element required to create the VPN connection was not installed.

All resolved now.

Thanks for your assistance.

C
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.