Solved

C:\ is not accessible access is denied

Posted on 2012-03-12
7
2,365 Views
Last Modified: 2012-03-17
Between Sunday afternoon and this morning, we started having permission problems on a file and remote desktop server. It is server 2008 R2, running as a VM under vSphere 5.0

The most pressing issue right now is not being able to access drive c:. There were also permission issues on drive shares from another drive, but if I can fix this one, we can probably fix the other issues.

The drive shows in the list, but clicking on it gives the above message.  I have logged on under the local administrator account, a domain administrator account and my own user account, all with same effect.

output of icacls command from my account:

C:\Users\JIM>icacls c:\
c:\: Access is denied.
Successfully processed 0 files; Failed processing 1 files

C:\Users\JIM>

It is the same under the local administrator account and a domain administrator account.

Reading another issue on EE, I tried using the command to grant execute access to Users, but it failed.
0
Comment
Question by:jn2112
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 41

Expert Comment

by:Adam Brown
ID: 37711010
This is probably UAC getting in your way. Right click the command prompt and select Run as Administrator or disable UAC on the server and it should allow you access (assuming you are logged in as a user with Administrative permissions)
0
 

Accepted Solution

by:
NEIL10 earned 250 total points
ID: 37711031
Not sure if you have tried this however have you tried taking the ownership from the C:\. This may allow you to correct the corrupt ACL’s

- Right Click on System (C:)
- Select Properties
- Security Tab
- Owner Tab
-  Replace owner on subcontainers and Objects Check Box
- Apply
0
 

Assisted Solution

by:jn2112
jn2112 earned 0 total points
ID: 37711045
Opened cmd with Run-As-Administrator, same results for icacls. (logged on as local administrator)
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:jn2112
ID: 37711050
Also, no MMC snap-in will open. Most likely due to not having execute permission on c: drive.
0
 

Author Comment

by:jn2112
ID: 37711064
UAC is off on this server.
0
 
LVL 41

Assisted Solution

by:Adam Brown
Adam Brown earned 250 total points
ID: 37711089
Check the ownership as Neil recommends. Also, you might have a virus on that server, so I'd start looking into that.
0
 

Author Closing Comment

by:jn2112
ID: 37732272
Thanks for your help.
0

Featured Post

Enroll in July's Course of the Month

July's Course of the Month is now available! Enroll to learn HTML5 and prepare for certification. It's free for Premium Members, Team Accounts, and Qualified Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Suggested Courses

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question