Solved

Exchange 2010 "Cannot import certificate. A certificate with the thumbprint already exists"

Posted on 2012-03-12
5
9,602 Views
Last Modified: 2012-03-12
Hello Folks,

I purchased a single domain cert though Godaddy and imported it into Exhange 2010 without a problem. At that time, I had a self signed certificate previously installed but I have since deleted that. I am trying to replace the cert with a multiple domain cert from Godaddy but I get the error message: "Cannot import certifiate. A certificate witht he thumbprint already exists". I have tried manually removing the previous cert though the MMC and with EMS with no luck. Any suggestions for me anyone?

Greatly Appreciated,

John
0
Comment
Question by:JohnnyD74
  • 2
  • 2
5 Comments
 
LVL 8

Expert Comment

by:Elmar-H
ID: 37711395
Restart iis :-) (www publishingservice)
0
 
LVL 8

Accepted Solution

by:
Elmar-H earned 500 total points
ID: 37711403
Open mmc and add cert snapin, computeraccount, own certs. Here you find the cert for removal. Or via iis management console...
0
 
LVL 42

Expert Comment

by:Amit
ID: 37711440
0
 

Author Comment

by:JohnnyD74
ID: 37711444
Thanks. I did these things but I still cannot import the SSL. It completed the import but is still in "pending" mode. Should I delte the cert in IIS as well?
0
 

Author Comment

by:JohnnyD74
ID: 37711584
I deleted all the Godaddy certs from the MMC and it then worked after a reboot!
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question