Excel 2010 will not paste formulas

My Excel is acting up. When I copy and paste.  It will not paste the formulas. When I right click, only the text option is available.  I have done the following:

Reboot
scandisk
removed office 2010 and reinstalled
open only one application of Excel with only one Excel 2010 xlsx file open.

With this I still have the problem.  It is not the file.  The same file works file on my desktop PC.  It is only on my laptop.  

Your help would be appreciated.

Tom
ThomasJueAsked:
Who is Participating?
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Hello,

this problem has been reported all over the web. Skype is the culprit. The click to call add-in for web browsers were interfering with the MS Office paste options.

http://blogs.skype.com/garage/2012/04/skype_click_to_call_fix_for_of.html

cheers, teylyn
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Hello,

what do you see when you open the Paste Special dialogue? Copy something, then right click a target cell, select Paste Special.

Check File > Options > Advanced and make sure that all options in the section "Cut, copy and paste" are selected.

cheers, teylyn
0
 
ThomasJueAuthor Commented:
teylyn,

>>what do you see when you open the Paste Special dialogue? Copy something, then right click a target cell, select Paste Special.
[tom]  Only the icon "A" ("Keep Text Only") is showing.

Check File > Options > Advanced and make sure that all options in the section "Cut, copy and paste" are selected
[tom]  Yes, all boxes here are checked.

[tom} I opened this file from DropBox (www.dropbox.com) and thought that was presenting some sort of read-only problem.  

I then copied this file to my C drive, closed it and opened it and still have the same problem.  

Yet, when I open this file with my other computer and Excel 2010, I don't have this problem.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
What happens with a new workbook. Can you see the complete paste options there?
0
 
ThomasJueAuthor Commented:
Teylyn

>>>What happens with a new workbook. Can you see the complete paste options there?

[tom]
I closed Excel complete. I did not reboot.  I then opened a new Excel workbook.
I inserted a formula and copied it.
On the paste option, again, only the "A" icon appears.

Sometimes when I re-boot, it works okay for a little while and then reverts back to this problem.

Tom
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Do you have any add-ins loaded? Any files that load when Excel is started?

This is certainly not normal behaviour and it looks as if something is overriding Excel's default settings.
0
 
ThomasJueAuthor Commented:
>>>Do you have any add-ins loaded? Any files that load when Excel is started?

[tom]
I have a bunch of add-in's.  See atached file.  However, I added nothing new for about a month.
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Nothing attached.

Suggest you disable all add-ins. Then see if the paste special options are back. Then enable one add-in after the other and check in between.

cheers, teylyn
0
 
ThomasJueAuthor Commented:
Excel Add-ins are now attached.

Now that I am reviewing it, I only have 3 active ones:  

QBExcelReportUpdater and QQube.

I will remove these.

Tom
Excel-Add-ins.pdf
0
 
ThomasJueAuthor Commented:
I removed the add-ins.  I closed and restarted Excel.  The problem is still there.  It won't paste formulas.

Tom
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Try starting Excel in Safe Mode, as described  here http://support.microsoft.com/kb/280504#LetMeFixItMyselfAlways1

Click Start, and then click Run.
Click Browse, and then locate the folder where Microsoft Excel is installed, as specified earlier in this article.
After you locate the Excel.exe file, click the file to select it, and then click Open.
At the end of the path in the Open box, type a space and then type /s so that the entire line appears similar to the following:
"C:\Program Files\Microsoft Office\Office\Excel.exe" /s

This will open Excel without anything added in or running in the background.

If you still don't see the paste special options, then I'm really at a loss.
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Here's what I see when I run in safe mode, copy a cell and use Alt - e - s to open the paste special dialogue.
screenshot
0
 
ThomasJueAuthor Commented:
>>Click Start, and then click Run.
My Windows 7 does not show a "Run" when click on Start.

Tom
0
 
ThomasJueAuthor Commented:
teylyn

I was poking around trying to do the "run".  I located the Excel.exe as you suggested.  I right clicked on it.  There was a "Run as administrator" option.  See the attached upload.  I tried this and it worked.  I can now paste formulas again.  Question is:
1.  Is this a good solution?
2.  How do I get it to run as admnistrator all the time as the default?

Tom
0
 
ThomasJueAuthor Commented:
teylyn,

The "Run as administrator" option only worked for a while and then the pasting as values took over again, leaving me no other options.  

I am now working on the "Compatibility Mode".  I changed it from "Windows 7" to "Windows XP (Service Pak 3)".  It seems to be working for now.

My other PC which is running Windows 7, Excel 2010 fine,  is running as  "Windows XP (Service Pak 3)".  However, I do not recall changing  my HP Laptop  when I began to experience this problem.  My HP Laptop is Windows 7, Office 2010.

I will keep working on this and report my findings tomorrow morning.  

Tom
snap001849-Excel-Compatibility.pdf
0
 
ThomasJueAuthor Commented:
teylyn,

I have an Acronis backup of my C drive from late January 2011.  I keep my programs on the C drive and my data on other drives.  I just did a restore.  Everything seems to be working okay.  As a side note, I also have a Windows 7 Image as a secondary backup.

I suspect it may have to do with Windows 7 operating system that administers multi-sessions of Excel.  The only software I had added inbetween was Skype.  I'll run it for the rest of the day and report back.

Tom
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Thanks for the update. It sure sounds more like a problem with the local setup rather than an Excel setting.
0
 
ThomasJueAuthor Commented:
teylyn,

I have been working with Excel all day.  I only had one instance this morning where the Ctl+V resulted in a value paste.  However, I did an immediate paste with a right click and all the options for pasting showed up ... whew!  

Due to the randomness of this problem.  I will keep this open for one more day before I close it.  Again, thank goodness for Acronis.  Thank you.

Tom
0
 
ThomasJueAuthor Commented:
I do have Skype loaded on my laptop.  I did this right around the time I had this problem.  Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.