Solved

Replication error 14151

Posted on 2012-03-12
6
1,490 Views
Last Modified: 2012-06-21
Replication error started recently on a previously working system.  Both servers running SQL 2005, in the same domain, both logged in using the same domain admin service account.  I have rebooted both servers and have completely rebuilt the replication process from the ground up, with no joy.

The distribution database gives this error message (14151) every time the repl. agent job runs:

Replication-Replication Distribution Subsystem: agent HOU-CX-01-CT-ca_tables-HOU-SQL02-5 failed. The process could not connect to Subscriber 'HOU-SQL02'.

I can ping the subscriber system with no problem.  

Thanks in advance for any help!
0
Comment
Question by:Clothahump
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 75

Assisted Solution

by:Anthony Perkins
Anthony Perkins earned 250 total points
ID: 37712816
I would suspect the account you are using to connect the publisher to the subscriber no longer has access.
0
 
LVL 4

Author Comment

by:Clothahump
ID: 37715086
It's a domain admin account.  All of the other servers that rep to this one connect with it, so I don't think that's the issue.
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 37717681
Than I am afraid I have no idea.
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 4

Accepted Solution

by:
Clothahump earned 0 total points
ID: 37729812
Okay, I found the solution.  Even though the SQL Browser showed that it was running and in automatic status, something must have goobered it up.  I restarted it and was able to get replication running again.

ACPerkins, thanks for trying to help.
0
 
LVL 4

Author Comment

by:Clothahump
ID: 37737333
ACPerkins, I'm awarding you 250 points for trying to help me.  Thanks!
0
 
LVL 4

Author Closing Comment

by:Clothahump
ID: 37760252
My solution was the one that got replication running again.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've encountered valid database schemas that do not have a primary key.  For example, I use LogParser from Microsoft to push IIS logs into a SQL database table for processing and analysis.  However, occasionally due to user error or a scheduled task…
So every once in a while at work I am asked to export data from one table and insert it into another on a different server.  I hate doing this.  There's so many different tables and data types.  Some column data needs quoted and some doesn't.  What …
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question